summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/lz4/lz4_1.7.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/lz4/lz4_1.7.4.bb')
-rw-r--r--meta/recipes-support/lz4/lz4_1.7.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-support/lz4/lz4_1.7.4.bb b/meta/recipes-support/lz4/lz4_1.7.4.bb
new file mode 100644
index 0000000000..5ddffd54b9
--- /dev/null
+++ b/meta/recipes-support/lz4/lz4_1.7.4.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Extremely Fast Compression algorithm"
2DESCRIPTION = "LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems."
3
4LICENSE = "BSD | BSD-2-Clause | GPL-2.0"
5LIC_FILES_CHKSUM = "file://lib/LICENSE;md5=ebc2ea4814a64de7708f1571904b32cc\
6 file://programs/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://LICENSE;md5=7f2857d58beff6d04137bf9b09e5ffb6"
8
9PE = "1"
10
11SRCREV = "7bb64ff2b69a9f8367de9ab483cdadf42b4c1b65"
12
13SRC_URI = "git://github.com/lz4/lz4.git \
14 file://run-ptest \
15"
16
17S = "${WORKDIR}/git"
18inherit ptest
19
20EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}"
21
22do_install() {
23 oe_runmake install
24}
25
26do_install_ptest () {
27 install -d ${D}${PTEST_PATH}/testsuite
28 cp -rf ${S}/* ${D}${PTEST_PATH}/testsuite
29}
30
31RDEPENDS_${PN}-ptest += "make python3"
32
33BBCLASSEXTEND = "native nativesdk"