summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libxslt/libxslt_1.1.34.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libxslt/libxslt_1.1.34.bb')
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.34.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.34.bb b/meta/recipes-support/libxslt/libxslt_1.1.34.bb
new file mode 100644
index 0000000000..ad37b5a44a
--- /dev/null
+++ b/meta/recipes-support/libxslt/libxslt_1.1.34.bb
@@ -0,0 +1,49 @@
1SUMMARY = "GNOME XSLT library"
2HOMEPAGE = "http://xmlsoft.org/XSLT/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
7
8SECTION = "libs"
9DEPENDS = "libxml2"
10
11SRC_URI = "http://xmlsoft.org/sources/libxslt-${PV}.tar.gz \
12 "
13
14SRC_URI[md5sum] = "db8765c8d076f1b6caafd9f2542a304a"
15SRC_URI[sha256sum] = "98b1bd46d6792925ad2dfe9a87452ea2adebf69dcb9919ffd55bf926a7f93f7f"
16
17UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar"
18
19S = "${WORKDIR}/libxslt-${PV}"
20
21BINCONFIG = "${bindir}/xslt-config"
22
23inherit autotools pkgconfig binconfig-disabled lib_package
24
25do_configure_prepend () {
26 # We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header.
27 # This can be removed when upgrading to 1.1.34.
28 sed -i -e 's/ansidecl.h//' ${S}/configure.ac
29
30 # The timestamps in the 1.1.28 tarball are messed up causing this file to
31 # appear out of date. Touch it so that we don't try to regenerate it.
32 touch ${S}/doc/xsltproc.1
33}
34
35EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto --with-html-subdir=${BPN}"
36# older versions of this recipe had ${PN}-utils
37RPROVIDES_${PN}-bin += "${PN}-utils"
38RCONFLICTS_${PN}-bin += "${PN}-utils"
39RREPLACES_${PN}-bin += "${PN}-utils"
40
41# This is only needed until libxml can load the relocated catalog itself
42do_install_append_class-native () {
43 create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog
44}
45
46FILES_${PN} += "${libdir}/libxslt-plugins"
47FILES_${PN}-dev += "${libdir}/xsltConf.sh"
48
49BBCLASSEXTEND = "native nativesdk"