summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libxslt/libxslt_1.1.28.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libxslt/libxslt_1.1.28.bb')
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.28.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.28.bb b/meta/recipes-support/libxslt/libxslt_1.1.28.bb
new file mode 100644
index 0000000000..ded883e457
--- /dev/null
+++ b/meta/recipes-support/libxslt/libxslt_1.1.28.bb
@@ -0,0 +1,46 @@
1SUMMARY = "GNOME XSLT library"
2HOMEPAGE = "http://xmlsoft.org/XSLT/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
7
8SECTION = "libs"
9DEPENDS = "libxml2"
10
11SRC_URI = "ftp://xmlsoft.org/libxslt//libxslt-${PV}.tar.gz \
12 file://pkgconfig_fix.patch \
13 file://pkgconfig.patch"
14
15SRC_URI[md5sum] = "9667bf6f9310b957254fdcf6596600b7"
16SRC_URI[sha256sum] = "5fc7151a57b89c03d7b825df5a0fae0a8d5f05674c0e7cf2937ecec4d54a028c"
17S = "${WORKDIR}/libxslt-${PV}"
18
19BINCONFIG = "${bindir}/xslt-config"
20
21inherit autotools pkgconfig binconfig-disabled lib_package
22
23# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
24do_configure_prepend () {
25 sed -i -e 's/ansidecl.h//' ${S}/configure.in
26
27 # The timestamps in the 1.1.28 tarball are messed up causing this file to
28 # appear out of date. Touch it so that we don't try to regenerate it.
29 touch ${S}/doc/xsltproc.1
30}
31
32EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
33# older versions of this recipe had ${PN}-utils
34RPROVIDES_${PN}-bin += "${PN}-utils"
35RCONFLICTS_${PN}-bin += "${PN}-utils"
36RREPLACES_${PN}-bin += "${PN}-utils"
37
38
39do_install_append_class-native () {
40 create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog.xml
41}
42
43FILES_${PN} += "${libdir}/libxslt-plugins"
44FILES_${PN}-dev += "${libdir}/xsltConf.sh"
45
46BBCLASSEXTEND = "native"