diff options
Diffstat (limited to 'meta/recipes-support/libsoup/libsoup_3.6.4.bb')
-rw-r--r-- | meta/recipes-support/libsoup/libsoup_3.6.4.bb | 59 |
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-support/libsoup/libsoup_3.6.4.bb b/meta/recipes-support/libsoup/libsoup_3.6.4.bb new file mode 100644 index 0000000000..4d50e1353e --- /dev/null +++ b/meta/recipes-support/libsoup/libsoup_3.6.4.bb | |||
@@ -0,0 +1,59 @@ | |||
1 | SUMMARY = "An HTTP library implementation in C" | ||
2 | DESCRIPTION = "libsoup is an HTTP client/server library for GNOME. It uses GObjects \ | ||
3 | and the glib main loop, to integrate well with GNOME applications." | ||
4 | HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup" | ||
5 | BUGTRACKER = "https://bugzilla.gnome.org/" | ||
6 | SECTION = "x11/gnome/libs" | ||
7 | LICENSE = "LGPL-2.0-only" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" | ||
9 | |||
10 | DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 libpsl nghttp2" | ||
11 | |||
12 | SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" | ||
13 | |||
14 | SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz" | ||
15 | SRC_URI[sha256sum] = "9b54c76f5276b05bebcaf2b6c2a141a188fc7bb1d0624eda259dac13a6665c8a" | ||
16 | |||
17 | PROVIDES = "libsoup-3.0" | ||
18 | CVE_PRODUCT = "libsoup" | ||
19 | |||
20 | S = "${WORKDIR}/libsoup-${PV}" | ||
21 | |||
22 | inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gi-docgen vala | ||
23 | |||
24 | GIR_MESON_ENABLE_FLAG = 'enabled' | ||
25 | GIR_MESON_DISABLE_FLAG = 'disabled' | ||
26 | |||
27 | PACKAGECONFIG ??= "" | ||
28 | PACKAGECONFIG[brotli] = "-Dbrotli=enabled,-Dbrotli=disabled,brotli" | ||
29 | PACKAGECONFIG[gssapi] = "-Dgssapi=enabled,-Dgssapi=disabled,krb5" | ||
30 | PACKAGECONFIG[ntlm] = "-Dntlm=enabled,-Dntlm=disabled" | ||
31 | PACKAGECONFIG[sysprof] = "-Dsysprof=enabled,-Dsysprof=disabled,sysprof" | ||
32 | |||
33 | # Tell libsoup where the target ntlm_auth is installed | ||
34 | do_write_config:append:class-target() { | ||
35 | cat >${WORKDIR}/soup.cross <<EOF | ||
36 | [binaries] | ||
37 | ntlm_auth = '${bindir}/ntlm_auth' | ||
38 | EOF | ||
39 | } | ||
40 | EXTRA_OEMESON:append:class-target = " --cross-file ${WORKDIR}/soup.cross" | ||
41 | |||
42 | EXTRA_OEMESON += "-Dtls_check=false" | ||
43 | # Disable the test suites | ||
44 | EXTRA_OEMESON += "-Dtests=false -Dautobahn=disabled -Dpkcs11_tests=disabled" | ||
45 | |||
46 | GIDOCGEN_MESON_OPTION = 'docs' | ||
47 | GIDOCGEN_MESON_ENABLE_FLAG = 'enabled' | ||
48 | GIDOCGEN_MESON_DISABLE_FLAG = 'disabled' | ||
49 | |||
50 | # When built without gnome support, libsoup will contain only one shared lib | ||
51 | # and will therefore become subject to renaming by debian.bbclass. Prevent | ||
52 | # renaming in order to keep the package name consistent regardless of whether | ||
53 | # gnome support is enabled or disabled. | ||
54 | DEBIAN_NOAUTONAME:${PN} = "1" | ||
55 | |||
56 | # glib-networking is needed for SSL, proxies, etc. | ||
57 | RRECOMMENDS:${PN} = "glib-networking" | ||
58 | |||
59 | BBCLASSEXTEND = "native nativesdk" | ||