summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libsoup/libsoup-2.4_2.66.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libsoup/libsoup-2.4_2.66.1.bb')
-rw-r--r--meta/recipes-support/libsoup/libsoup-2.4_2.66.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-support/libsoup/libsoup-2.4_2.66.1.bb b/meta/recipes-support/libsoup/libsoup-2.4_2.66.1.bb
new file mode 100644
index 0000000000..f0043f80b3
--- /dev/null
+++ b/meta/recipes-support/libsoup/libsoup-2.4_2.66.1.bb
@@ -0,0 +1,38 @@
1SUMMARY = "An HTTP library implementation in C"
2HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome/libs"
5LICENSE = "LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
7
8DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native libpsl"
9
10SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
11
12SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz \
13 file://0001-Do-not-enforce-no-introspection-when-cross-building.patch \
14 "
15SRC_URI[md5sum] = "5f04c09a06f6dbe4c4d3f003992145ce"
16SRC_URI[sha256sum] = "4a2cb6c1174540af13661636035992c2b179dfcb39f4d3fa7bee3c7e355c43ff"
17
18S = "${WORKDIR}/libsoup-${PV}"
19
20inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc
21
22# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default.
23PACKAGECONFIG ??= ""
24PACKAGECONFIG[gnome] = "-Dgnome=true,-Dgnome=false"
25PACKAGECONFIG[gssapi] = "-Dgssapi=true,-Dgssapi=false,krb5"
26
27EXTRA_OEMESON_append = " -Dvapi=false"
28
29GTKDOC_MESON_OPTION = "doc"
30
31# When built without gnome support, libsoup-2.4 will contain only one shared lib
32# and will therefore become subject to renaming by debian.bbclass. Prevent
33# renaming in order to keep the package name consistent regardless of whether
34# gnome support is enabled or disabled.
35DEBIAN_NOAUTONAME_${PN} = "1"
36
37# glib-networking is needed for SSL, proxies, etc.
38RRECOMMENDS_${PN} = "glib-networking"