summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libsoup/libsoup-2.4_2.64.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libsoup/libsoup-2.4_2.64.2.bb')
-rw-r--r--meta/recipes-support/libsoup/libsoup-2.4_2.64.2.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-support/libsoup/libsoup-2.4_2.64.2.bb b/meta/recipes-support/libsoup/libsoup-2.4_2.64.2.bb
new file mode 100644
index 0000000000..9f852d5c05
--- /dev/null
+++ b/meta/recipes-support/libsoup/libsoup-2.4_2.64.2.bb
@@ -0,0 +1,34 @@
1SUMMARY = "An HTTP library implementation in C"
2HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome/libs"
5LICENSE = "LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
7
8DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native libpsl"
9
10SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
11
12SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
13SRC_URI[md5sum] = "cac755dc6c6acd6e0c70007f547548f5"
14SRC_URI[sha256sum] = "75ddc194a5b1d6f25033bb9d355f04bfe5c03e0e1c71ed0774104457b3a786c6"
15
16S = "${WORKDIR}/libsoup-${PV}"
17
18inherit autotools gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc
19
20# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default.
21PACKAGECONFIG ??= ""
22PACKAGECONFIG[gnome] = "--with-gnome,--without-gnome"
23PACKAGECONFIG[gssapi] = "--with-gssapi,--without-gssapi,krb5"
24
25EXTRA_OECONF = "--disable-vala"
26
27# When built without gnome support, libsoup-2.4 will contain only one shared lib
28# and will therefore become subject to renaming by debian.bbclass. Prevent
29# renaming in order to keep the package name consistent regardless of whether
30# gnome support is enabled or disabled.
31DEBIAN_NOAUTONAME_${PN} = "1"
32
33# glib-networking is needed for SSL, proxies, etc.
34RRECOMMENDS_${PN} = "glib-networking"