summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libsoup/libsoup-2.4_2.54.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libsoup/libsoup-2.4_2.54.1.bb')
-rw-r--r--meta/recipes-support/libsoup/libsoup-2.4_2.54.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-support/libsoup/libsoup-2.4_2.54.1.bb b/meta/recipes-support/libsoup/libsoup-2.4_2.54.1.bb
new file mode 100644
index 0000000000..ad8202ce7f
--- /dev/null
+++ b/meta/recipes-support/libsoup/libsoup-2.4_2.54.1.bb
@@ -0,0 +1,34 @@
1SUMMARY = "An HTTP library implementation in C"
2HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome/libs"
5LICENSE = "LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
7
8DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native"
9
10SHRT_VER = "${@d.getVar('PV', True).split('.')[0]}.${@d.getVar('PV', True).split('.')[1]}"
11
12SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
13
14SRC_URI[md5sum] = "73b1fb774de16c29b380f87016f9f9dd"
15SRC_URI[sha256sum] = "47b42c232034734d66e5f093025843a5d8cc4b2357c011085a2fd04ef02dd633"
16
17S = "${WORKDIR}/libsoup-${PV}"
18
19inherit autotools gettext pkgconfig upstream-version-is-even gobject-introspection
20
21# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default.
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[gnome] = "--with-gnome,--without-gnome"
24
25EXTRA_OECONF = "--disable-vala"
26
27# When built without gnome support, libsoup-2.4 will contain only one shared lib
28# and will therefore become subject to renaming by debian.bbclass. Prevent
29# renaming in order to keep the package name consistent regardless of whether
30# gnome support is enabled or disabled.
31DEBIAN_NOAUTONAME_${PN} = "1"
32
33# glib-networking is needed for SSL, proxies, etc.
34RRECOMMENDS_${PN} = "glib-networking"