summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libsoup/libsoup-2.4_2.52.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libsoup/libsoup-2.4_2.52.2.bb')
-rw-r--r--meta/recipes-support/libsoup/libsoup-2.4_2.52.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-support/libsoup/libsoup-2.4_2.52.2.bb b/meta/recipes-support/libsoup/libsoup-2.4_2.52.2.bb
new file mode 100644
index 0000000000..b342bbd74b
--- /dev/null
+++ b/meta/recipes-support/libsoup/libsoup-2.4_2.52.2.bb
@@ -0,0 +1,30 @@
1SUMMARY = "An HTTP library implementation in C"
2HOMEPAGE = "http://www.gnome.org/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
7
8SECTION = "x11/gnome/libs"
9
10DEPENDS = "glib-2.0 gnutls libxml2 sqlite3 intltool-native"
11
12EXTRA_OECONF = "--disable-vala"
13
14# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Enable
15# by default but let it be easily disabled.
16PACKAGECONFIG ??= "gnome"
17PACKAGECONFIG[gnome] = "--with-gnome,--without-gnome"
18
19SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
20SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
21
22SRC_URI[md5sum] = "e4757d09012ed93822b1ee41435fec24"
23SRC_URI[sha256sum] = "db55628b5c7d952945bb71b236469057c8dfb8dea0c271513579c6273c2093dc"
24
25S = "${WORKDIR}/libsoup-${PV}"
26
27inherit autotools gettext pkgconfig upstream-version-is-even
28
29# glib-networking is needed for SSL, proxies, etc.
30RRECOMMENDS_${PN} = "glib-networking"