summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libsoup/libsoup-2.4_2.44.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libsoup/libsoup-2.4_2.44.2.bb')
-rw-r--r--meta/recipes-support/libsoup/libsoup-2.4_2.44.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/libsoup/libsoup-2.4_2.44.2.bb b/meta/recipes-support/libsoup/libsoup-2.4_2.44.2.bb
new file mode 100644
index 0000000000..5edbb090de
--- /dev/null
+++ b/meta/recipes-support/libsoup/libsoup-2.4_2.44.2.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "An HTTP library implementation in C"
2HOMEPAGE = "http://www.gnome.org/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
7
8SECTION = "x11/gnome/libs"
9
10DEPENDS = "glib-2.0 gnutls libxml2 libproxy sqlite3"
11
12# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Enable
13# by default but let it be easily disabled.
14PACKAGECONFIG ??= "gnome"
15PACKAGECONFIG[gnome] = "--with-gnome,--without-gnome"
16
17SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
18SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
19
20SRC_URI[md5sum] = "92aa3667357157e8f3489bcca287f2fa"
21SRC_URI[sha256sum] = "e7e4b5ab74a6c00fc267c9f5963852d28759ad3154dab6388e2d6e1962d598f3"
22
23S = "${WORKDIR}/libsoup-${PV}"
24
25inherit autotools pkgconfig
26
27# glib-networking is needed for SSL, proxies, etc.
28RRECOMMENDS_${PN} = "glib-networking"