summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre_8.38.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre_8.38.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.38.bb75
1 files changed, 75 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.38.bb b/meta/recipes-support/libpcre/libpcre_8.38.bb
new file mode 100644
index 0000000000..a83a1fecc5
--- /dev/null
+++ b/meta/recipes-support/libpcre/libpcre_8.38.bb
@@ -0,0 +1,75 @@
1DESCRIPTION = "The PCRE library is a set of functions that implement regular \
2expression pattern matching using the same syntax and semantics as Perl 5. PCRE \
3has its own native API, as well as a set of wrapper functions that correspond \
4to the POSIX regular expression API."
5SUMMARY = "Perl Compatible Regular Expressions"
6HOMEPAGE = "http://www.pcre.org"
7SECTION = "devel"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=7e4937814aee14758c1c95b59c80c44d"
10SRC_URI = "${SOURCEFORGE_MIRROR}/project/pcre/pcre/${PV}/pcre-${PV}.tar.bz2 \
11 file://pcre-cross.patch \
12 file://fix-pcre-name-collision.patch \
13 file://run-ptest \
14 file://Makefile \
15"
16
17SRC_URI[md5sum] = "00aabbfe56d5a48b270f999b508c5ad2"
18SRC_URI[sha256sum] = "b9e02d36e23024d6c02a2e5b25204b3a4fa6ade43e0a5f869f254f49535079df"
19
20S = "${WORKDIR}/pcre-${PV}"
21
22PROVIDES += "pcre"
23DEPENDS += "bzip2 zlib"
24
25PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline,"
26
27BINCONFIG = "${bindir}/pcre-config"
28
29inherit autotools binconfig-disabled ptest
30
31PARALLEL_MAKE = ""
32
33EXTRA_OECONF = "\
34 --enable-newline-is-lf \
35 --enable-rebuild-chartables \
36 --enable-utf8 \
37 --with-link-size=2 \
38 --with-match-limit=10000000 \
39"
40
41# Set LINK_SIZE in BUILD_CFLAGS given that the autotools bbclass use it to
42# set CFLAGS_FOR_BUILD, required for the libpcre build.
43BUILD_CFLAGS =+ "-DLINK_SIZE=2 -I${B}"
44CFLAGS += "-D_REENTRANT"
45CXXFLAGS_append_powerpc = " -lstdc++"
46
47PACKAGES =+ "libpcrecpp libpcreposix pcregrep pcregrep-doc pcretest pcretest-doc"
48
49SUMMARY_libpcrecpp = "${SUMMARY} - C++ wrapper functions"
50SUMMARY_libpcreposix = "${SUMMARY} - C wrapper functions based on the POSIX regex API"
51SUMMARY_pcregrep = "grep utility that uses perl 5 compatible regexes"
52SUMMARY_pcregrep-doc = "grep utility that uses perl 5 compatible regexes - docs"
53SUMMARY_pcretest = "program for testing Perl-comatible regular expressions"
54SUMMARY_pcretest-doc = "program for testing Perl-comatible regular expressions - docs"
55
56FILES_libpcrecpp = "${libdir}/libpcrecpp.so.*"
57FILES_libpcreposix = "${libdir}/libpcreposix.so.*"
58FILES_pcregrep = "${bindir}/pcregrep"
59FILES_pcregrep-doc = "${mandir}/man1/pcregrep.1"
60FILES_pcretest = "${bindir}/pcretest"
61FILES_pcretest-doc = "${mandir}/man1/pcretest.1"
62
63BBCLASSEXTEND = "native nativesdk"
64
65do_install_ptest() {
66 t=${D}${PTEST_PATH}
67 cp ${WORKDIR}/Makefile $t
68 cp -r ${S}/testdata $t
69 for i in pcre_stringpiece_unittest pcregrep pcretest; \
70 do cp ${B}/.libs/$i $t; \
71 done
72 for i in RunTest RunGrepTest test-driver; \
73 do cp ${S}/$i $t; \
74 done
75}