summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre_8.38.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre_8.38.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.38.bb81
1 files changed, 81 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.38.bb b/meta/recipes-support/libpcre/libpcre_8.38.bb
new file mode 100644
index 0000000000..64bae5708a
--- /dev/null
+++ b/meta/recipes-support/libpcre/libpcre_8.38.bb
@@ -0,0 +1,81 @@
1DESCRIPTION = "The PCRE library is a set of functions that implement regular \
2expression pattern matching using the same syntax and semantics as Perl 5. PCRE \
3has its own native API, as well as a set of wrapper functions that correspond \
4to the POSIX regular expression API."
5SUMMARY = "Perl Compatible Regular Expressions"
6HOMEPAGE = "http://www.pcre.org"
7SECTION = "devel"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=7e4937814aee14758c1c95b59c80c44d"
10SRC_URI = "ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-${PV}.tar.bz2 \
11 file://pcre-cross.patch \
12 file://fix-pcre-name-collision.patch \
13 file://run-ptest \
14 file://Makefile \
15"
16
17SRC_URI[md5sum] = "00aabbfe56d5a48b270f999b508c5ad2"
18SRC_URI[sha256sum] = "b9e02d36e23024d6c02a2e5b25204b3a4fa6ade43e0a5f869f254f49535079df"
19
20UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/pcre/files/pcre/"
21UPSTREAM_CHECK_REGEX = "/pcre/(?P<pver>(\d+[\.\-_]*)+)/"
22
23S = "${WORKDIR}/pcre-${PV}"
24
25PROVIDES += "pcre"
26DEPENDS += "bzip2 zlib"
27
28PACKAGECONFIG ??= "pcre8"
29
30PACKAGECONFIG[pcre8] = "--enable-pcre8,--disable-pcre8"
31PACKAGECONFIG[pcre16] = "--enable-pcre16,--disable-pcre16"
32PACKAGECONFIG[pcre32] = "--enable-pcre32,--disable-pcre32"
33PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline,"
34
35BINCONFIG = "${bindir}/pcre-config"
36
37inherit autotools binconfig-disabled ptest
38
39EXTRA_OECONF = "\
40 --enable-newline-is-lf \
41 --enable-rebuild-chartables \
42 --enable-utf8 \
43 --with-link-size=2 \
44 --with-match-limit=10000000 \
45"
46
47# Set LINK_SIZE in BUILD_CFLAGS given that the autotools bbclass use it to
48# set CFLAGS_FOR_BUILD, required for the libpcre build.
49BUILD_CFLAGS =+ "-DLINK_SIZE=2 -I${B}"
50CFLAGS += "-D_REENTRANT"
51CXXFLAGS_append_powerpc = " -lstdc++"
52
53PACKAGES =+ "libpcrecpp libpcreposix pcregrep pcregrep-doc pcretest pcretest-doc"
54
55SUMMARY_libpcrecpp = "${SUMMARY} - C++ wrapper functions"
56SUMMARY_libpcreposix = "${SUMMARY} - C wrapper functions based on the POSIX regex API"
57SUMMARY_pcregrep = "grep utility that uses perl 5 compatible regexes"
58SUMMARY_pcregrep-doc = "grep utility that uses perl 5 compatible regexes - docs"
59SUMMARY_pcretest = "program for testing Perl-comatible regular expressions"
60SUMMARY_pcretest-doc = "program for testing Perl-comatible regular expressions - docs"
61
62FILES_libpcrecpp = "${libdir}/libpcrecpp.so.*"
63FILES_libpcreposix = "${libdir}/libpcreposix.so.*"
64FILES_pcregrep = "${bindir}/pcregrep"
65FILES_pcregrep-doc = "${mandir}/man1/pcregrep.1"
66FILES_pcretest = "${bindir}/pcretest"
67FILES_pcretest-doc = "${mandir}/man1/pcretest.1"
68
69BBCLASSEXTEND = "native nativesdk"
70
71do_install_ptest() {
72 t=${D}${PTEST_PATH}
73 cp ${WORKDIR}/Makefile $t
74 cp -r ${S}/testdata $t
75 for i in pcre_stringpiece_unittest pcregrep pcretest; \
76 do cp ${B}/.libs/$i $t; \
77 done
78 for i in RunTest RunGrepTest test-driver; \
79 do cp ${S}/$i $t; \
80 done
81}