summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre_8.38.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre_8.38.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.38.bb78
1 files changed, 78 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.38.bb b/meta/recipes-support/libpcre/libpcre_8.38.bb
new file mode 100644
index 0000000000..c5676073e8
--- /dev/null
+++ b/meta/recipes-support/libpcre/libpcre_8.38.bb
@@ -0,0 +1,78 @@
1DESCRIPTION = "The PCRE library is a set of functions that implement regular \
2expression pattern matching using the same syntax and semantics as Perl 5. PCRE \
3has its own native API, as well as a set of wrapper functions that correspond \
4to the POSIX regular expression API."
5SUMMARY = "Perl Compatible Regular Expressions"
6HOMEPAGE = "http://www.pcre.org"
7SECTION = "devel"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=7e4937814aee14758c1c95b59c80c44d"
10SRC_URI = "${SOURCEFORGE_MIRROR}/project/pcre/pcre/${PV}/pcre-${PV}.tar.bz2 \
11 file://pcre-cross.patch \
12 file://fix-pcre-name-collision.patch \
13 file://run-ptest \
14 file://Makefile \
15"
16
17SRC_URI[md5sum] = "00aabbfe56d5a48b270f999b508c5ad2"
18SRC_URI[sha256sum] = "b9e02d36e23024d6c02a2e5b25204b3a4fa6ade43e0a5f869f254f49535079df"
19
20S = "${WORKDIR}/pcre-${PV}"
21
22PROVIDES += "pcre"
23DEPENDS += "bzip2 zlib"
24
25PACKAGECONFIG ??= "pcre8"
26
27PACKAGECONFIG[pcre8] = "--enable-pcre8,--disable-pcre8"
28PACKAGECONFIG[pcre16] = "--enable-pcre16,--disable-pcre16"
29PACKAGECONFIG[pcre32] = "--enable-pcre32,--disable-pcre32"
30PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline,"
31
32BINCONFIG = "${bindir}/pcre-config"
33
34inherit autotools binconfig-disabled ptest
35
36EXTRA_OECONF = "\
37 --enable-newline-is-lf \
38 --enable-rebuild-chartables \
39 --enable-utf8 \
40 --with-link-size=2 \
41 --with-match-limit=10000000 \
42"
43
44# Set LINK_SIZE in BUILD_CFLAGS given that the autotools bbclass use it to
45# set CFLAGS_FOR_BUILD, required for the libpcre build.
46BUILD_CFLAGS =+ "-DLINK_SIZE=2 -I${B}"
47CFLAGS += "-D_REENTRANT"
48CXXFLAGS_append_powerpc = " -lstdc++"
49
50PACKAGES =+ "libpcrecpp libpcreposix pcregrep pcregrep-doc pcretest pcretest-doc"
51
52SUMMARY_libpcrecpp = "${SUMMARY} - C++ wrapper functions"
53SUMMARY_libpcreposix = "${SUMMARY} - C wrapper functions based on the POSIX regex API"
54SUMMARY_pcregrep = "grep utility that uses perl 5 compatible regexes"
55SUMMARY_pcregrep-doc = "grep utility that uses perl 5 compatible regexes - docs"
56SUMMARY_pcretest = "program for testing Perl-comatible regular expressions"
57SUMMARY_pcretest-doc = "program for testing Perl-comatible regular expressions - docs"
58
59FILES_libpcrecpp = "${libdir}/libpcrecpp.so.*"
60FILES_libpcreposix = "${libdir}/libpcreposix.so.*"
61FILES_pcregrep = "${bindir}/pcregrep"
62FILES_pcregrep-doc = "${mandir}/man1/pcregrep.1"
63FILES_pcretest = "${bindir}/pcretest"
64FILES_pcretest-doc = "${mandir}/man1/pcretest.1"
65
66BBCLASSEXTEND = "native nativesdk"
67
68do_install_ptest() {
69 t=${D}${PTEST_PATH}
70 cp ${WORKDIR}/Makefile $t
71 cp -r ${S}/testdata $t
72 for i in pcre_stringpiece_unittest pcregrep pcretest; \
73 do cp ${B}/.libs/$i $t; \
74 done
75 for i in RunTest RunGrepTest test-driver; \
76 do cp ${S}/$i $t; \
77 done
78}