diff options
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre_8.36.bb')
-rw-r--r-- | meta/recipes-support/libpcre/libpcre_8.36.bb | 75 |
1 files changed, 75 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.36.bb b/meta/recipes-support/libpcre/libpcre_8.36.bb new file mode 100644 index 0000000000..6aa0237aa4 --- /dev/null +++ b/meta/recipes-support/libpcre/libpcre_8.36.bb | |||
@@ -0,0 +1,75 @@ | |||
1 | DESCRIPTION = "The PCRE library is a set of functions that implement regular \ | ||
2 | expression pattern matching using the same syntax and semantics as Perl 5. PCRE \ | ||
3 | has its own native API, as well as a set of wrapper functions that correspond \ | ||
4 | to the POSIX regular expression API." | ||
5 | SUMMARY = "Perl Compatible Regular Expressions" | ||
6 | HOMEPAGE = "http://www.pcre.org" | ||
7 | SECTION = "devel" | ||
8 | LICENSE = "BSD" | ||
9 | LIC_FILES_CHKSUM = "file://LICENCE;md5=ded617e975f28e15952dc68b84a7ac1a" | ||
10 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/pcre/pcre/${PV}/pcre-${PV}.tar.bz2 \ | ||
11 | file://pcre-cross.patch \ | ||
12 | file://fix-pcre-name-collision.patch \ | ||
13 | file://run-ptest \ | ||
14 | file://Makefile \ | ||
15 | " | ||
16 | |||
17 | SRC_URI[md5sum] = "b767bc9af0c20bc9c1fe403b0d41ad97" | ||
18 | SRC_URI[sha256sum] = "ef833457de0c40e82f573e34528f43a751ff20257ad0e86d272ed5637eb845bb" | ||
19 | |||
20 | S = "${WORKDIR}/pcre-${PV}" | ||
21 | |||
22 | PROVIDES += "pcre" | ||
23 | DEPENDS += "bzip2 zlib" | ||
24 | |||
25 | PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline," | ||
26 | |||
27 | BINCONFIG = "${bindir}/pcre-config" | ||
28 | |||
29 | inherit autotools binconfig-disabled ptest | ||
30 | |||
31 | PARALLEL_MAKE = "" | ||
32 | |||
33 | EXTRA_OECONF = "\ | ||
34 | --enable-newline-is-lf \ | ||
35 | --enable-rebuild-chartables \ | ||
36 | --enable-utf8 \ | ||
37 | --with-link-size=2 \ | ||
38 | --with-match-limit=10000000 \ | ||
39 | " | ||
40 | |||
41 | # Set LINK_SIZE in BUILD_CFLAGS given that the autotools bbclass use it to | ||
42 | # set CFLAGS_FOR_BUILD, required for the libpcre build. | ||
43 | BUILD_CFLAGS =+ "-DLINK_SIZE=2 -I${B}" | ||
44 | CFLAGS += "-D_REENTRANT" | ||
45 | CXXFLAGS_append_powerpc = " -lstdc++" | ||
46 | |||
47 | PACKAGES =+ "libpcrecpp libpcreposix pcregrep pcregrep-doc pcretest pcretest-doc" | ||
48 | |||
49 | SUMMARY_libpcrecpp = "${SUMMARY} - C++ wrapper functions" | ||
50 | SUMMARY_libpcreposix = "${SUMMARY} - C wrapper functions based on the POSIX regex API" | ||
51 | SUMMARY_pcregrep = "grep utility that uses perl 5 compatible regexes" | ||
52 | SUMMARY_pcregrep-doc = "grep utility that uses perl 5 compatible regexes - docs" | ||
53 | SUMMARY_pcretest = "program for testing Perl-comatible regular expressions" | ||
54 | SUMMARY_pcretest-doc = "program for testing Perl-comatible regular expressions - docs" | ||
55 | |||
56 | FILES_libpcrecpp = "${libdir}/libpcrecpp.so.*" | ||
57 | FILES_libpcreposix = "${libdir}/libpcreposix.so.*" | ||
58 | FILES_pcregrep = "${bindir}/pcregrep" | ||
59 | FILES_pcregrep-doc = "${mandir}/man1/pcregrep.1" | ||
60 | FILES_pcretest = "${bindir}/pcretest" | ||
61 | FILES_pcretest-doc = "${mandir}/man1/pcretest.1" | ||
62 | |||
63 | BBCLASSEXTEND = "native nativesdk" | ||
64 | |||
65 | do_install_ptest() { | ||
66 | t=${D}${PTEST_PATH} | ||
67 | cp ${WORKDIR}/Makefile $t | ||
68 | cp -r ${S}/testdata $t | ||
69 | for i in pcre_stringpiece_unittest pcregrep pcretest; \ | ||
70 | do cp ${B}/.libs/$i $t; \ | ||
71 | done | ||
72 | for i in RunTest RunGrepTest test-driver; \ | ||
73 | do cp ${S}/$i $t; \ | ||
74 | done | ||
75 | } | ||