summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre_8.34.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre_8.34.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.34.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.34.bb b/meta/recipes-support/libpcre/libpcre_8.34.bb
index 0c2b0828b1..5c5072cb90 100644
--- a/meta/recipes-support/libpcre/libpcre_8.34.bb
+++ b/meta/recipes-support/libpcre/libpcre_8.34.bb
@@ -9,7 +9,10 @@ LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=0920cc1a9f7ba95464491fa83c86afd8" 9LIC_FILES_CHKSUM = "file://LICENCE;md5=0920cc1a9f7ba95464491fa83c86afd8"
10SRC_URI = "${SOURCEFORGE_MIRROR}/project/pcre/pcre/${PV}/pcre-${PV}.tar.bz2 \ 10SRC_URI = "${SOURCEFORGE_MIRROR}/project/pcre/pcre/${PV}/pcre-${PV}.tar.bz2 \
11 file://pcre-cross.patch \ 11 file://pcre-cross.patch \
12 file://fix-pcre-name-collision.patch" 12 file://fix-pcre-name-collision.patch \
13 file://run-ptest \
14 file://Makefile \
15"
13 16
14SRC_URI[md5sum] = "5439e321351bddd5533551bbce128d07" 17SRC_URI[md5sum] = "5439e321351bddd5533551bbce128d07"
15SRC_URI[sha256sum] = "b6043ae1ff2720be665ffa28dc22b7c637cdde96f389a116c0c3020caeae583f" 18SRC_URI[sha256sum] = "b6043ae1ff2720be665ffa28dc22b7c637cdde96f389a116c0c3020caeae583f"
@@ -21,7 +24,7 @@ DEPENDS += "bzip2 zlib"
21 24
22PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline," 25PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline,"
23 26
24inherit autotools binconfig 27inherit autotools binconfig ptest
25 28
26PARALLEL_MAKE = "" 29PARALLEL_MAKE = ""
27 30
@@ -56,3 +59,15 @@ FILES_pcretest = "${bindir}/pcretest"
56FILES_pcretest-doc = "${mandir}/man1/pcretest.1" 59FILES_pcretest-doc = "${mandir}/man1/pcretest.1"
57 60
58BBCLASSEXTEND = "native nativesdk" 61BBCLASSEXTEND = "native nativesdk"
62
63do_install_ptest() {
64 t=${D}${PTEST_PATH}
65 cp ${WORKDIR}/Makefile $t
66 cp -r ${S}/testdata $t
67 for i in pcre_stringpiece_unittest pcregrep pcretest; \
68 do cp ${B}/.libs/$i $t; \
69 done
70 for i in RunTest RunGrepTest test-driver; \
71 do cp ${S}/$i $t; \
72 done
73}