summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre_8.33.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre_8.33.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.33.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.33.bb b/meta/recipes-support/libpcre/libpcre_8.33.bb
new file mode 100644
index 0000000000..50930b42bd
--- /dev/null
+++ b/meta/recipes-support/libpcre/libpcre_8.33.bb
@@ -0,0 +1,60 @@
1DESCRIPTION = "The PCRE library is a set of functions that implement regular \
2expression pattern matching using the same syntax and semantics as Perl 5. PCRE \
3has its own native API, as well as a set of wrapper functions that correspond \
4to the POSIX regular expression API."
5SUMMARY = "Perl Compatible Regular Expressions"
6HOMEPAGE = "http://www.pcre.org"
7SECTION = "devel"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=0920cc1a9f7ba95464491fa83c86afd8"
10SRC_URI = "${SOURCEFORGE_MIRROR}/project/pcre/pcre/${PV}/pcre-${PV}.tar.bz2 \
11 file://pcre-cross.patch \
12 file://fix-pcre-name-collision.patch"
13
14SRC_URI[md5sum] = "21514018448ac10062ece7a668fca949"
15SRC_URI[sha256sum] = "c603957a4966811c04af5f6048c71cfb4966ec93312d7b3118116ed9f3bc0478"
16
17S = "${WORKDIR}/pcre-${PV}"
18
19FILESPATH .= ":${@base_set_filespath([bb.which(BBPATH, 'recipes-support/libpcre/files', direction=True)], d)}"
20
21PROVIDES += "pcre"
22DEPENDS += "bzip2 zlib"
23
24PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline,"
25
26inherit autotools binconfig
27
28PARALLEL_MAKE = ""
29
30EXTRA_OECONF = "\
31 --enable-newline-is-lf \
32 --enable-rebuild-chartables \
33 --enable-utf8 \
34 --with-link-size=2 \
35 --with-match-limit=10000000 \
36"
37
38# Set LINK_SIZE in BUILD_CFLAGS given that the autotools bbclass use it to
39# set CFLAGS_FOR_BUILD, required for the libpcre build.
40BUILD_CFLAGS =+ "-DLINK_SIZE=2 -I${B}"
41CFLAGS += "-D_REENTRANT"
42CXXFLAGS_append_powerpc = " -lstdc++"
43
44PACKAGES =+ "libpcrecpp libpcreposix pcregrep pcregrep-doc pcretest pcretest-doc"
45
46SUMMARY_libpcrecpp = "${SUMMARY} - C++ wrapper functions"
47SUMMARY_libpcreposix = "${SUMMARY} - C wrapper functions based on the POSIX regex API"
48SUMMARY_pcregrep = "grep utility that uses perl 5 compatible regexes"
49SUMMARY_pcregrep-doc = "grep utility that uses perl 5 compatible regexes - docs"
50SUMMARY_pcretest = "program for testing Perl-comatible regular expressions"
51SUMMARY_pcretest-doc = "program for testing Perl-comatible regular expressions - docs"
52
53FILES_libpcrecpp = "${libdir}/libpcrecpp.so.*"
54FILES_libpcreposix = "${libdir}/libpcreposix.so.*"
55FILES_pcregrep = "${bindir}/pcregrep"
56FILES_pcregrep-doc = "${mandir}/man1/pcregrep.1"
57FILES_pcretest = "${bindir}/pcretest"
58FILES_pcretest-doc = "${mandir}/man1/pcretest.1"
59
60BBCLASSEXTEND = "native nativesdk"