summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre_8.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre_8.20.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.20.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.20.bb b/meta/recipes-support/libpcre/libpcre_8.20.bb
new file mode 100644
index 0000000000..58c6ecf9a7
--- /dev/null
+++ b/meta/recipes-support/libpcre/libpcre_8.20.bb
@@ -0,0 +1,55 @@
1DESCRIPTION = "Perl-compatible regular expression library. PCRE has its own native \
2API, but a set of 'wrapper' functions that are based on the POSIX API \
3are also supplied in the library libpcreposix. Note that this just \
4provides a POSIX calling interface to PCRE; the regular expressions \
5themselves still follow Perl syntax and semantics. The header file for \
6the POSIX-style functions is called pcreposix.h."
7SECTION = "devel"
8PR = "r0"
9LICENSE = "BSD"
10LIC_FILES_CHKSUM = "file://LICENCE;md5=2f00d186a775c8002422a5315079d96b"
11SRC_URI = "${SOURCEFORGE_MIRROR}/pcre/pcre-${PV}.tar.bz2 \
12 file://pcre-cross.patch \
13 file://fix-pcre-name-collision.patch"
14
15SRC_URI[md5sum] = "a1931c70e1273e3450d5036fe273d25c"
16SRC_URI[sha256sum] = "e06b0943ce4b0f15324a20020d6086760a75b72f5ad7c23b9b2bfe690ed49acd"
17S = "${WORKDIR}/pcre-${PV}"
18
19PROVIDES = "pcre"
20DEPENDS = "bzip2 zlib readline"
21
22inherit autotools binconfig
23
24PARALLEL_MAKE = ""
25
26CFLAGS_append = " -D_REENTRANT"
27CXXFLAGS_powerpc += "-lstdc++"
28EXTRA_OECONF = " --with-link-size=2 --enable-newline-is-lf --with-match-limit=10000000 --enable-rebuild-chartables --enable-utf8"
29
30do_compile () {
31 # stop libtool from trying to link with host libraries - fix from #33
32 # this resolve build problem on amd64 - #1015
33 if [ -e ${S}/${HOST_SYS}-libtool ] ; then
34 sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${HOST_SYS}-libtool
35 else
36 ln -sf ${S}/libtool ${S}/${HOST_SYS}-libtool
37 sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${HOST_SYS}-libtool
38 fi
39
40 # The generation of dftables can lead to timestamp problems with ccache
41 # because the generated config.h seems newer. It is sufficient to ensure that the
42 # attempt to build dftables inside make will actually work (foo_FOR_BUILD is
43 # only used for this).
44 oe_runmake CC_FOR_BUILD="${BUILD_CC}" CFLAGS_FOR_BUILD="-DLINK_SIZE=2 -I${S}/include" LINK_FOR_BUILD="${BUILD_CC} -L${S}/lib"
45}
46
47python populate_packages_prepend () {
48 pcre_libdir = bb.data.expand('${libdir}', d)
49 do_split_packages(d, pcre_libdir, '^lib(.*)\.so\.+', 'lib%s', 'libpcre %s library', extra_depends='', allow_links=True)
50}
51
52FILES_${PN} = "${libdir}/libpcre.so.*"
53FILES_${PN}-dev += "${bindir}/*"
54
55BBCLASSEXTEND = "native"