summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre_8.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre_8.12.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.12.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.12.bb b/meta/recipes-support/libpcre/libpcre_8.12.bb
new file mode 100644
index 0000000000..0301ddb30b
--- /dev/null
+++ b/meta/recipes-support/libpcre/libpcre_8.12.bb
@@ -0,0 +1,58 @@
1DESCRIPTION = "Perl-compatible regular expression library. PCRE has its own native \
2API, but a set of 'wrapper' functions that are based on the POSIX API \
3are also supplied in the library libpcreposix. Note that this just \
4provides a POSIX calling interface to PCRE; the regular expressions \
5themselves still follow Perl syntax and semantics. The header file for \
6the POSIX-style functions is called pcreposix.h."
7SECTION = "devel"
8PR = "r0"
9LICENSE = "BSD"
10LIC_FILES_CHKSUM = "file://LICENCE;md5=77f9b14fe707d0376d89bc162e6c54ff"
11SRC_URI = "${SOURCEFORGE_MIRROR}/pcre/pcre-${PV}.tar.bz2 \
12 file://pcre-cross.patch;patch=1 \
13 file://fix-pcre-name-collision.patch"
14
15SRC_URI[md5sum] = "f14a9fef3c92f3fc6c5ac92d7a2c7eb3"
16SRC_URI[sha256sum] = "c63070d461edc451ec9457f2324e152a531e907d5c5d2d8f8121e725acd1aeec"
17S = "${WORKDIR}/pcre-${PV}"
18
19PROVIDES = "pcre"
20
21inherit autotools binconfig
22
23PARALLEL_MAKE = ""
24
25CFLAGS_append = " -D_REENTRANT"
26CXXFLAGS_powerpc += "-lstdc++"
27EXTRA_OECONF = " --with-link-size=2 --enable-newline-is-lf --with-match-limit=10000000 --enable-rebuild-chartables --enable-utf8"
28
29do_compile () {
30 # stop libtool from trying to link with host libraries - fix from #33
31 # this resolve build problem on amd64 - #1015
32 if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
33 sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${TARGET_SYS}-libtool
34 else
35 ln -sf ${S}/libtool ${S}/${TARGET_SYS}-libtool
36 sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${TARGET_SYS}-libtool
37 fi
38
39 # The generation of dftables can lead to timestamp problems with ccache
40 # because the generated config.h seems newer. It is sufficient to ensure that the
41 # attempt to build dftables inside make will actually work (foo_FOR_BUILD is
42 # only used for this).
43 oe_runmake CC_FOR_BUILD="${BUILD_CC}" CFLAGS_FOR_BUILD="-DLINK_SIZE=2 -I${S}/include" LINK_FOR_BUILD="${BUILD_CC} -L${S}/lib"
44}
45
46python populate_packages_prepend () {
47 pcre_libdir = bb.data.expand('${libdir}', d)
48 pcre_libdir_dbg = bb.data.expand('${libdir}/.debug', d)
49 do_split_packages(d, pcre_libdir, '^lib(.*)\.so$', 'lib%s-dev', 'libpcre %s development package', extra_depends='${PN}-dev', allow_links=True)
50 do_split_packages(d, pcre_libdir, '^lib(.*)\.la$', 'lib%s-dev', 'libpcre %s development package', extra_depends='${PN}-dev')
51 do_split_packages(d, pcre_libdir, '^lib(.*)\.a$', 'lib%s-dev', 'libpcre %s development package', extra_depends='${PN}-dev')
52 do_split_packages(d, pcre_libdir, '^lib(.*)\.so\.*', 'lib%s', 'libpcre %s library', extra_depends='', allow_links=True)
53}
54
55FILES_${PN} = "${libdir}/libpcre.so.*"
56FILES_${PN}-dev += "${bindir}/*"
57
58BBCLASSEXTEND = "native"