summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre_8.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre_8.10.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.10.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.10.bb b/meta/recipes-support/libpcre/libpcre_8.10.bb
new file mode 100644
index 0000000000..840d74a658
--- /dev/null
+++ b/meta/recipes-support/libpcre/libpcre_8.10.bb
@@ -0,0 +1,53 @@
1DESCRIPTION = "Perl-compatible regular expression library. PCRE has its own native \
2API, but a set of 'wrapper' functions that are based on the POSIX API \
3are also supplied in the library libpcreposix. Note that this just \
4provides a POSIX calling interface to PCRE; the regular expressions \
5themselves still follow Perl syntax and semantics. The header file for \
6the POSIX-style functions is called pcreposix.h."
7SECTION = "devel"
8PR = "r4"
9LICENSE = "BSD"
10SRC_URI = "${SOURCEFORGE_MIRROR}/pcre/pcre-${PV}.tar.bz2 \
11 file://pcre-cross.patch;patch=1"
12S = "${WORKDIR}/pcre-${PV}"
13
14PROVIDES = "pcre"
15
16inherit autotools binconfig
17
18PARALLEL_MAKE = ""
19
20CFLAGS_append = " -D_REENTRANT"
21CXXFLAGS_powerpc += "-lstdc++"
22EXTRA_OECONF = " --with-link-size=2 --enable-newline-is-lf --with-match-limit=10000000 --enable-rebuild-chartables --enable-utf8"
23
24do_compile () {
25 # stop libtool from trying to link with host libraries - fix from #33
26 # this resolve build problem on amd64 - #1015
27 if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
28 sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${TARGET_SYS}-libtool
29 else
30 ln -sf ${S}/libtool ${S}/${TARGET_SYS}-libtool
31 sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${TARGET_SYS}-libtool
32 fi
33
34 # The generation of dftables can lead to timestamp problems with ccache
35 # because the generated config.h seems newer. It is sufficient to ensure that the
36 # attempt to build dftables inside make will actually work (foo_FOR_BUILD is
37 # only used for this).
38 oe_runmake CC_FOR_BUILD="${BUILD_CC}" CFLAGS_FOR_BUILD="-DLINK_SIZE=2 -I${S}/include" LINK_FOR_BUILD="${BUILD_CC} -L${S}/lib"
39}
40
41python populate_packages_prepend () {
42 pcre_libdir = bb.data.expand('${libdir}', d)
43 pcre_libdir_dbg = bb.data.expand('${libdir}/.debug', d)
44 do_split_packages(d, pcre_libdir, '^lib(.*)\.so$', 'lib%s-dev', 'libpcre %s development package', extra_depends='${PN}-dev', allow_links=True)
45 do_split_packages(d, pcre_libdir, '^lib(.*)\.la$', 'lib%s-dev', 'libpcre %s development package', extra_depends='${PN}-dev')
46 do_split_packages(d, pcre_libdir, '^lib(.*)\.a$', 'lib%s-dev', 'libpcre %s development package', extra_depends='${PN}-dev')
47 do_split_packages(d, pcre_libdir, '^lib(.*)\.so\.*', 'lib%s', 'libpcre %s library', extra_depends='', allow_links=True)
48}
49
50FILES_${PN} = "${libdir}/libpcre.so.*"
51FILES_${PN}-dev += "${bindir}/*"
52
53BBCLASSEXTEND = "native"