summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.73.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.73.bb')
-rw-r--r--meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.73.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.73.bb b/meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.73.bb
new file mode 100644
index 0000000000..219f0c44d6
--- /dev/null
+++ b/meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.73.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3LICENSE = "LGPL-2.1+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36"
5SECTION = "net"
6
7DEPENDS = "file"
8
9SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz"
10SRC_URI[md5sum] = "2b15949b1633e4fa487e08cdcc97f0e3"
11SRC_URI[sha256sum] = "a37b2f1b88fd1bfe74109586be463a434d34e773530fc2a74364cfcf734c032e"
12
13inherit autotools lib_package pkgconfig gettext
14
15CFLAGS += "-pthread -D_REENTRANT"
16
17EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
18
19PACKAGECONFIG ?= "curl https"
20PACKAGECONFIG_append_class-target = "\
21 ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \
22"
23PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
24PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
25PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls,"
26
27do_compile_append() {
28 sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
29}
30
31BBCLASSEXTEND = "native nativesdk"