summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libjitterentropy/libjitterentropy_2.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libjitterentropy/libjitterentropy_2.1.2.bb')
-rw-r--r--meta/recipes-support/libjitterentropy/libjitterentropy_2.1.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/libjitterentropy/libjitterentropy_2.1.2.bb b/meta/recipes-support/libjitterentropy/libjitterentropy_2.1.2.bb
new file mode 100644
index 0000000000..3b5b4e4aa0
--- /dev/null
+++ b/meta/recipes-support/libjitterentropy/libjitterentropy_2.1.2.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Hardware RNG based on CPU timing jitter"
2DESCRIPTION = "The Jitter RNG provides a noise source using the CPU execution timing jitter. \
3It does not depend on any system resource other than a high-resolution time \
4stamp. It is a small-scale, yet fast entropy source that is viable in almost \
5all environments and on a lot of CPU architectures."
6HOMEPAGE = "http://www.chronox.de/jent.html"
7LICENSE = "GPLv2+ | BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=e52365752b36cfcd7f9601d80de7d8c6 \
9 file://COPYING.gplv2;md5=eb723b61539feef013de476e68b5c50a \
10 file://COPYING.bsd;md5=66a5cedaf62c4b2637025f049f9b826f \
11 "
12SRC_URI = "git://github.com/smuellerDD/jitterentropy-library.git \
13 file://0001-fix-do_install-failure-on-oe.patch \
14 "
15SRCREV = "f5a80c6f3fcc6deebd0eabf75324f48aed1afbce"
16S = "${WORKDIR}/git"
17
18do_configure[noexec] = "1"
19
20LDFLAGS += "-Wl,-O0"
21
22do_install () {
23 oe_runmake install INCDIR="/include" \
24 DESTDIR="${D}" \
25 PREFIX="${exec_prefix}" \
26 LIBDIR="${baselib}"
27}
28