summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libiconv/libiconv_1.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libiconv/libiconv_1.14.bb')
-rw-r--r--meta/recipes-support/libiconv/libiconv_1.14.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-support/libiconv/libiconv_1.14.bb b/meta/recipes-support/libiconv/libiconv_1.14.bb
new file mode 100644
index 0000000000..1b6fe09bb7
--- /dev/null
+++ b/meta/recipes-support/libiconv/libiconv_1.14.bb
@@ -0,0 +1,51 @@
1SUMMARY = "Character encoding support library"
2DESCRIPTION = "GNU libiconv - libiconv is for you if your application needs to support \
3multiple character encodings, but that support lacks from your system."
4HOMEPAGE = "http://www.gnu.org/software/libiconv"
5SECTION = "libs"
6NOTES = "Needs to be stripped down to: ascii iso8859-1 eucjp iso-2022jp gb utf8"
7PROVIDES = "virtual/libiconv"
8PR = "r1"
9LICENSE = "LGPLv3"
10LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=9f604d8a4f8e74f4f5140845a21b6674 \
11 file://libcharset/COPYING.LIB;md5=9f604d8a4f8e74f4f5140845a21b6674"
12
13SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz \
14 file://autoconf.patch \
15 file://add-relocatable-module.patch \
16 "
17
18SRC_URI[md5sum] = "e34509b1623cec449dfeb73d7ce9c6c6"
19SRC_URI[sha256sum] = "72b24ded17d687193c3366d0ebe7cde1e6b18f0df8c55438ac95be39e8a30613"
20
21S = "${WORKDIR}/libiconv-${PV}"
22
23inherit autotools pkgconfig gettext
24
25python __anonymous() {
26 if d.getVar("TARGET_OS", True) != "linux":
27 return
28 if d.getVar("TCLIBC", True) == "glibc":
29 raise bb.parse.SkipPackage("libiconv is provided for use with uClibc only - glibc already provides iconv")
30}
31
32EXTRA_OECONF += "--enable-shared --enable-static --enable-relocatable"
33
34LEAD_SONAME = "libiconv.so"
35
36do_configure_prepend () {
37 rm -f ${S}/m4/libtool.m4 ${S}/m4/ltoptions.m4 ${S}/m4/ltsugar.m4 ${S}/m4/ltversion.m4 ${S}/m4/lt~obsolete.m4 ${S}/libcharset/m4/libtool.m4 ${S}/libcharset/m4/ltoptions.m4 ${S}/libcharset/m4/ltsugar.m4 ${S}/libcharset/m4/ltversion.m4 ${S}/libcharset/m4/lt~obsolete.m4
38}
39
40do_configure_append () {
41 # forcibly remove RPATH from libtool
42 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' *libtool
43 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=_NO_RPATH_|g' *libtool
44}
45
46do_install_append () {
47 rm -rf ${D}${libdir}/preloadable_libiconv.so
48 rm -rf ${D}${libdir}/charset.alias
49}
50
51BBCLASSEXTEND = "nativesdk"