summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libical/libical_3.0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libical/libical_3.0.6.bb')
-rw-r--r--meta/recipes-support/libical/libical_3.0.6.bb24
1 files changed, 16 insertions, 8 deletions
diff --git a/meta/recipes-support/libical/libical_3.0.6.bb b/meta/recipes-support/libical/libical_3.0.6.bb
index 032f3655e9..f9be898a12 100644
--- a/meta/recipes-support/libical/libical_3.0.6.bb
+++ b/meta/recipes-support/libical/libical_3.0.6.bb
@@ -7,27 +7,35 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1910a2a76ddf6a9ba369182494170d87 \
7 file://LICENSE.MPL2.txt;md5=9741c346eef56131163e13b9db1241b3" 7 file://LICENSE.MPL2.txt;md5=9741c346eef56131163e13b9db1241b3"
8SECTION = "libs" 8SECTION = "libs"
9 9
10SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz" 10SRC_URI = " \
11 11 https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz \
12 file://0001-Use-our-hand-build-native-src-generator.patch \
13"
12SRC_URI[md5sum] = "463a59244c6767b8e67b29379405e297" 14SRC_URI[md5sum] = "463a59244c6767b8e67b29379405e297"
13SRC_URI[sha256sum] = "5c8a21c2b732ece4a33e5c862970b4f35a8548bbcda50de5695f6fc211ac4d97" 15SRC_URI[sha256sum] = "5c8a21c2b732ece4a33e5c862970b4f35a8548bbcda50de5695f6fc211ac4d97"
14UPSTREAM_CHECK_URI = "https://github.com/libical/libical/releases" 16UPSTREAM_CHECK_URI = "https://github.com/libical/libical/releases"
15 17
16inherit cmake pkgconfig 18inherit cmake pkgconfig
17 19
18PACKAGECONFIG ??= "icu" 20do_compile_prepend() {
21 # As long as https://github.com/libical/libical/issues/394 is open build native src-generator manually
22 NATIVE_CFLAGS="${BUILD_CFLAGS} `pkg-config-native --cflags glib-2.0` `pkg-config-native --cflags libxml-2.0`"
23 NATIVE_LDFLAGS="${BUILD_LDFLAGS} `pkg-config-native --libs glib-2.0` `pkg-config-native --libs libxml-2.0`"
24 ${BUILD_CC} $NATIVE_CFLAGS ${S}/src/libical-glib/tools/generator.c ${S}/src/libical-glib/tools/xml-parser.c -o ${B}/src-generator $NATIVE_LDFLAGS
25}
26
27PACKAGECONFIG ??= "icu glib"
19PACKAGECONFIG[bdb] = ",-DCMAKE_DISABLE_FIND_PACKAGE_BDB=True,db" 28PACKAGECONFIG[bdb] = ",-DCMAKE_DISABLE_FIND_PACKAGE_BDB=True,db"
29PACKAGECONFIG[glib] = "-DICAL_GLIB=True,-DICAL_GLIB=False,glib-2.0-native libxml2-native glib-2.0 libxml2"
20# ICU is used for RSCALE (RFC7529) support 30# ICU is used for RSCALE (RFC7529) support
21PACKAGECONFIG[icu] = ",-DCMAKE_DISABLE_FIND_PACKAGE_ICU=True,icu" 31PACKAGECONFIG[icu] = ",-DCMAKE_DISABLE_FIND_PACKAGE_ICU=True,icu"
22 32
23# No need to use perl-native, the host perl is sufficient. 33# No need to use perl-native, the host perl is sufficient.
24EXTRA_OECMAKE += "-DPERL_EXECUTABLE=${HOSTTOOLS_DIR}/perl" 34EXTRA_OECMAKE += "-DPERL_EXECUTABLE=${HOSTTOOLS_DIR}/perl"
35# doc build fails with linker error (??) for libical-glib so disable it
36EXTRA_OECMAKE += "-DICAL_BUILD_DOCS=false"
25 37
26# The glib library can't be cross-compiled, disable for now. 38do_install_append () {
27# https://github.com/libical/libical/issues/394
28EXTRA_OECMAKE += "-DICAL_GLIB=false"
29
30do_install_append_class-target () {
31 # Remove build host references 39 # Remove build host references
32 sed -i \ 40 sed -i \
33 -e 's,${STAGING_LIBDIR},${libdir},g' \ 41 -e 's,${STAGING_LIBDIR},${libdir},g' \