diff options
Diffstat (limited to 'meta/recipes-support/libical/libical_3.0.14.bb')
-rw-r--r-- | meta/recipes-support/libical/libical_3.0.14.bb | 53 |
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-support/libical/libical_3.0.14.bb b/meta/recipes-support/libical/libical_3.0.14.bb new file mode 100644 index 0000000000..756100297e --- /dev/null +++ b/meta/recipes-support/libical/libical_3.0.14.bb | |||
@@ -0,0 +1,53 @@ | |||
1 | SUMMARY = "iCal and scheduling (RFC 2445, 2446, 2447) library" | ||
2 | DESCRIPTION = "An Open Source implementation of the iCalendar protocols \ | ||
3 | and protocol data units. The iCalendar specification describes how \ | ||
4 | calendar clients can communicate with calendar servers so users can store \ | ||
5 | their calendar data and arrange meetings with other users. " | ||
6 | HOMEPAGE = "https://github.com/libical/libical" | ||
7 | BUGTRACKER = "https://github.com/libical/libical/issues" | ||
8 | LICENSE = "LGPLv2.1 | MPL-2.0" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1910a2a76ddf6a9ba369182494170d87 \ | ||
10 | file://LICENSE.LGPL21.txt;md5=933adb561f159e7c3da079536f0ed871 \ | ||
11 | file://LICENSE.MPL2.txt;md5=f75d2927d3c1ed2414ef72048f5ad640 \ | ||
12 | " | ||
13 | SECTION = "libs" | ||
14 | |||
15 | SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz" | ||
16 | SRC_URI[sha256sum] = "4284b780356f1dc6a01f16083e7b836e63d3815e27ed0eaaad684712357ccc8f" | ||
17 | UPSTREAM_CHECK_URI = "https://github.com/libical/libical/releases" | ||
18 | |||
19 | inherit cmake pkgconfig gobject-introspection vala | ||
20 | |||
21 | DEPENDS += "libical-native" | ||
22 | |||
23 | PACKAGECONFIG ??= "icu glib" | ||
24 | PACKAGECONFIG[bdb] = ",-DCMAKE_DISABLE_FIND_PACKAGE_BDB=True,db" | ||
25 | PACKAGECONFIG[glib] = "-DICAL_GLIB=True,-DICAL_GLIB=False,glib-2.0-native libxml2-native glib-2.0 libxml2" | ||
26 | # ICU is used for RSCALE (RFC7529) support | ||
27 | PACKAGECONFIG[icu] = ",-DCMAKE_DISABLE_FIND_PACKAGE_ICU=True,icu" | ||
28 | |||
29 | # No need to use perl-native, the host perl is sufficient. | ||
30 | EXTRA_OECMAKE += "-DPERL_EXECUTABLE=${HOSTTOOLS_DIR}/perl" | ||
31 | # Disable the test suite as we can't install it | ||
32 | EXTRA_OECMAKE += "-DLIBICAL_BUILD_TESTING=false" | ||
33 | # doc build fails with linker error (??) for libical-glib so disable it | ||
34 | EXTRA_OECMAKE += "-DICAL_BUILD_DOCS=false" | ||
35 | # gobject-introspection | ||
36 | EXTRA_OECMAKE:append:class-target = " -DGObjectIntrospection_COMPILER=${STAGING_BINDIR}/g-ir-compiler-wrapper" | ||
37 | EXTRA_OECMAKE:append:class-target = " -DGObjectIntrospection_SCANNER=${STAGING_BINDIR}/g-ir-scanner-wrapper" | ||
38 | EXTRA_OECMAKE += "-DVAPIGEN=${STAGING_BINDIR_NATIVE}/vapigen" | ||
39 | EXTRA_OECMAKE += "${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DGOBJECT_INTROSPECTION=ON -DICAL_GLIB_VAPI=ON', '-DGOBJECT_INTROSPECTION=OFF', d)}" | ||
40 | |||
41 | # Tell the cross-libical where the tool it needs to build is | ||
42 | EXTRA_OECMAKE:append:class-target = " -DIMPORT_ICAL_GLIB_SRC_GENERATOR=${STAGING_LIBDIR_NATIVE}/cmake/LibIcal/IcalGlibSrcGenerator.cmake" | ||
43 | |||
44 | do_install:append () { | ||
45 | # Remove build host references (https://github.com/libical/libical/issues/532) | ||
46 | sed -i \ | ||
47 | -e 's,${STAGING_LIBDIR},${libdir},g' \ | ||
48 | -e 's,${STAGING_INCDIR},${includedir},g' \ | ||
49 | ${D}${libdir}/cmake/LibIcal/LibIcal*.cmake \ | ||
50 | ${D}${libdir}/cmake/LibIcal/Ical*.cmake | ||
51 | } | ||
52 | |||
53 | BBCLASSEXTEND = "native" | ||