summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgpg-error/libgpg-error_1.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libgpg-error/libgpg-error_1.18.bb')
-rw-r--r--meta/recipes-support/libgpg-error/libgpg-error_1.18.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-support/libgpg-error/libgpg-error_1.18.bb b/meta/recipes-support/libgpg-error/libgpg-error_1.18.bb
new file mode 100644
index 0000000000..9501b67b05
--- /dev/null
+++ b/meta/recipes-support/libgpg-error/libgpg-error_1.18.bb
@@ -0,0 +1,55 @@
1SUMMARY = "Small library that defines common error values for all GnuPG components"
2HOMEPAGE = "http://www.gnupg.org/related_software/libgpg-error/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4
5LICENSE = "GPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
7 file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
8 file://src/gpg-error.h.in;endline=23;md5=8b204918f0ca707136394d8bb20c7ebc \
9 file://src/init.c;endline=20;md5=8f5a9b59634f4aebcd0ec9d3ebd53bfe"
10
11
12SECTION = "libs"
13
14SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-${PV}.tar.bz2 \
15 file://pkgconfig.patch"
16SRC_URI[md5sum] = "12312802d2065774b787cbfc22cc04e9"
17SRC_URI[sha256sum] = "9ff1d6e61d4cef7c1d0607ceef6d40dc33f3da7a3094170c3718c00153d80810"
18
19BINCONFIG = "${bindir}/gpg-error-config"
20
21inherit autotools binconfig-disabled pkgconfig gettext
22
23do_compile_prepend() {
24 TARGET_FILE=linux-gnu
25 if [ ${TARGET_OS} != "linux" ]; then
26 TARGET_FILE=${TARGET_OS}
27 fi
28
29 case ${TARGET_ARCH} in
30 aarch64) TUPLE=aarch64-unknown-linux-gnu ;;
31 arm) TUPLE=arm-unknown-linux-gnueabi ;;
32 armeb) TUPLE=arm-unknown-linux-gnueabi ;;
33 i586) TUPLE=i486-pc-linux-gnu ;;
34 mipsel) TUPLE=mipsel-unknown-linux-gnu ;;
35 mips64el) TUPLE=mipsel-unknown-linux-gnu ;;
36 mips64) TUPLE=mips-unknown-linux-gnu ;;
37 mips) TUPLE=mips-unknown-linux-gnu ;;
38 powerpc64) TUPLE=powerpc64-unknown-linux-gnu ;;
39 powerpc) TUPLE=powerpc-unknown-linux-gnu ;;
40 sh4) TUPLE=sh4-unknown-linux-gnu ;;
41 x86_64) TUPLE=x86_64-pc-linux-gnu ;;
42 esac
43
44 cp ${S}/src/syscfg/lock-obj-pub.$TUPLE.h \
45 ${S}/src/syscfg/lock-obj-pub.$TARGET_FILE.h
46}
47
48do_install_append() {
49 # we don't have common lisp in OE
50 rm -rf "${D}${datadir}/common-lisp/"
51}
52
53FILES_${PN}-dev += "${bindir}/gpg-error"
54
55BBCLASSEXTEND = "native"