summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgpg-error/libgpg-error_1.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libgpg-error/libgpg-error_1.17.bb')
-rw-r--r--meta/recipes-support/libgpg-error/libgpg-error_1.17.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-support/libgpg-error/libgpg-error_1.17.bb b/meta/recipes-support/libgpg-error/libgpg-error_1.17.bb
new file mode 100644
index 0000000000..c905bd1eb1
--- /dev/null
+++ b/meta/recipes-support/libgpg-error/libgpg-error_1.17.bb
@@ -0,0 +1,56 @@
1SUMMARY = "Small library that defines common error values for all GnuPG components"
2HOMEPAGE = "http://www.gnupg.org/related_software/libgpg-error/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4
5LICENSE = "GPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
7 file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
8 file://src/gpg-error.h.in;endline=23;md5=5dfe776dc8b62af093ddc859de6f494c \
9 file://src/init.c;endline=20;md5=8f5a9b59634f4aebcd0ec9d3ebd53bfe"
10
11
12SECTION = "libs"
13
14SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-${PV}.tar.bz2 \
15 file://pkgconfig.patch"
16
17SRC_URI[md5sum] = "b4f8d8b9ff14aed41f279aa844563539"
18SRC_URI[sha256sum] = "3ff4e5a71116eb862cd14185fcd282850927b8608e3b4186834fd940fbef57b5"
19
20BINCONFIG = "${bindir}/gpg-error-config"
21
22inherit autotools binconfig-disabled pkgconfig gettext
23
24do_compile_prepend() {
25 TARGET_FILE=linux-gnu
26 if [ ${TARGET_OS} != "linux" ]; then
27 TARGET_FILE=${TARGET_OS}
28 fi
29
30 case ${TARGET_ARCH} in
31 aarch64) TUPLE=aarch64-unknown-linux-gnu ;;
32 arm) TUPLE=arm-unknown-linux-gnueabi ;;
33 armeb) TUPLE=arm-unknown-linux-gnueabi ;;
34 i586) TUPLE=i486-pc-linux-gnu ;;
35 mipsel) TUPLE=mipsel-unknown-linux-gnu ;;
36 mips64el) TUPLE=mipsel-unknown-linux-gnu ;;
37 mips64) TUPLE=mips-unknown-linux-gnu ;;
38 mips) TUPLE=mips-unknown-linux-gnu ;;
39 powerpc64) TUPLE=powerpc64-unknown-linux-gnu ;;
40 powerpc) TUPLE=powerpc-unknown-linux-gnu ;;
41 sh4) TUPLE=sh4-unknown-linux-gnu ;;
42 x86_64) TUPLE=x86_64-pc-linux-gnu ;;
43 esac
44
45 cp ${S}/src/syscfg/lock-obj-pub.$TUPLE.h \
46 ${S}/src/syscfg/lock-obj-pub.$TARGET_FILE.h
47}
48
49do_install_append() {
50 # we don't have common lisp in OE
51 rm -rf "${D}${datadir}/common-lisp/"
52}
53
54FILES_${PN}-dev += "${bindir}/gpg-error"
55
56BBCLASSEXTEND = "native"