diff options
Diffstat (limited to 'meta/recipes-support/libgcrypt/libgcrypt_1.8.4.bb')
-rw-r--r-- | meta/recipes-support/libgcrypt/libgcrypt_1.8.4.bb | 54 |
1 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-support/libgcrypt/libgcrypt_1.8.4.bb b/meta/recipes-support/libgcrypt/libgcrypt_1.8.4.bb new file mode 100644 index 0000000000..fda68a2938 --- /dev/null +++ b/meta/recipes-support/libgcrypt/libgcrypt_1.8.4.bb | |||
@@ -0,0 +1,54 @@ | |||
1 | SUMMARY = "General purpose cryptographic library based on the code from GnuPG" | ||
2 | HOMEPAGE = "http://directory.fsf.org/project/libgcrypt/" | ||
3 | BUGTRACKER = "https://bugs.g10code.com/gnupg/index" | ||
4 | SECTION = "libs" | ||
5 | |||
6 | # helper program gcryptrnd and getrandom are under GPL, rest LGPL | ||
7 | LICENSE = "GPLv2+ & LGPLv2.1+ & GPLv3+" | ||
8 | LICENSE_${PN} = "LGPLv2.1+" | ||
9 | LICENSE_${PN}-dev = "GPLv2+ & LGPLv2.1+" | ||
10 | LICENSE_dumpsexp-dev = "GPLv3+" | ||
11 | |||
12 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
13 | file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff \ | ||
14 | file://LICENSES;md5=840e3bcb754e5046ffeda7619034cbd8" | ||
15 | |||
16 | DEPENDS = "libgpg-error" | ||
17 | |||
18 | UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html" | ||
19 | SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.bz2 \ | ||
20 | file://0001-Add-and-use-pkg-config-for-libgcrypt-instead-of-conf.patch \ | ||
21 | file://0003-tests-bench-slope.c-workaround-ICE-failure-on-mips-w.patch \ | ||
22 | file://0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch \ | ||
23 | file://0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch \ | ||
24 | " | ||
25 | SRC_URI[md5sum] = "fbfdaebbbc6d7e5fbbf6ffdb3e139573" | ||
26 | SRC_URI[sha256sum] = "f638143a0672628fde0cad745e9b14deb85dffb175709cacc1f4fe24b93f2227" | ||
27 | |||
28 | BINCONFIG = "${bindir}/libgcrypt-config" | ||
29 | |||
30 | inherit autotools texinfo binconfig-disabled pkgconfig | ||
31 | |||
32 | EXTRA_OECONF = "--disable-asm" | ||
33 | EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'" | ||
34 | |||
35 | PACKAGECONFIG ??= "capabilities" | ||
36 | PACKAGECONFIG[capabilities] = "--with-capabilities,--without-capabilities,libcap" | ||
37 | |||
38 | do_configure_prepend () { | ||
39 | # Else this could be used in preference to the one in aclocal-copy | ||
40 | rm -f ${S}/m4/gpg-error.m4 | ||
41 | } | ||
42 | |||
43 | # libgcrypt.pc is added locally and thus installed here | ||
44 | do_install_append() { | ||
45 | install -d ${D}/${libdir}/pkgconfig | ||
46 | install -m 0644 ${B}/src/libgcrypt.pc ${D}/${libdir}/pkgconfig/ | ||
47 | } | ||
48 | |||
49 | PACKAGES =+ "dumpsexp-dev" | ||
50 | |||
51 | FILES_${PN}-dev += "${bindir}/hmac256" | ||
52 | FILES_dumpsexp-dev += "${bindir}/dumpsexp" | ||
53 | |||
54 | BBCLASSEXTEND = "native nativesdk" | ||