summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgcrypt/libgcrypt_1.7.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libgcrypt/libgcrypt_1.7.8.bb')
-rw-r--r--meta/recipes-support/libgcrypt/libgcrypt_1.7.8.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-support/libgcrypt/libgcrypt_1.7.8.bb b/meta/recipes-support/libgcrypt/libgcrypt_1.7.8.bb
new file mode 100644
index 0000000000..83351594ea
--- /dev/null
+++ b/meta/recipes-support/libgcrypt/libgcrypt_1.7.8.bb
@@ -0,0 +1,52 @@
1SUMMARY = "General purpose cryptographic library based on the code from GnuPG"
2HOMEPAGE = "http://directory.fsf.org/project/libgcrypt/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4SECTION = "libs"
5
6# helper program gcryptrnd and getrandom are under GPL, rest LGPL
7LICENSE = "GPLv2+ & LGPLv2.1+ & GPLv3+"
8LICENSE_${PN} = "LGPLv2.1+"
9LICENSE_${PN}-dev = "GPLv2+ & LGPLv2.1+"
10LICENSE_dumpsexp-dev = "GPLv3+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
13 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff"
14
15DEPENDS = "libgpg-error"
16
17UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
18SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.gz \
19 file://add-pkgconfig-support.patch \
20 file://libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch \
21 file://fix-ICE-failure-on-mips-with-option-O-and-g.patch \
22 file://fix-undefined-reference-to-pthread.patch \
23"
24SRC_URI[md5sum] = "5588b89b75b1353e2454b04c7b8368f3"
25SRC_URI[sha256sum] = "cb076b2efc7ba752f3d4c663c9ee0589a98b1d614fe90878b1facd607a45fd43"
26
27BINCONFIG = "${bindir}/libgcrypt-config"
28
29inherit autotools texinfo binconfig-disabled pkgconfig
30
31EXTRA_OECONF = "--disable-asm"
32
33PACKAGECONFIG ??= "capabilities"
34PACKAGECONFIG[capabilities] = "--with-capabilities,--without-capabilities,libcap"
35
36do_configure_prepend () {
37 # Else this could be used in preference to the one in aclocal-copy
38 rm -f ${S}/m4/gpg-error.m4
39}
40
41# libgcrypt.pc is added locally and thus installed here
42do_install_append() {
43 install -d ${D}/${libdir}/pkgconfig
44 install -m 0644 ${B}/src/libgcrypt.pc ${D}/${libdir}/pkgconfig/
45}
46
47PACKAGES =+ "dumpsexp-dev"
48
49FILES_${PN}-dev += "${bindir}/hmac256"
50FILES_dumpsexp-dev += "${bindir}/dumpsexp"
51
52BBCLASSEXTEND = "native nativesdk"