summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libffi/libffi_3.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libffi/libffi_3.4.2.bb')
-rw-r--r--meta/recipes-support/libffi/libffi_3.4.2.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-support/libffi/libffi_3.4.2.bb b/meta/recipes-support/libffi/libffi_3.4.2.bb
new file mode 100644
index 0000000000..47b230afa2
--- /dev/null
+++ b/meta/recipes-support/libffi/libffi_3.4.2.bb
@@ -0,0 +1,36 @@
1SUMMARY = "A portable foreign function interface library"
2HOMEPAGE = "http://sourceware.org/libffi/"
3DESCRIPTION = "The `libffi' library provides a portable, high level programming interface to various calling \
4conventions. This allows a programmer to call any function specified by a call interface description at run \
5time. FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the \
6interface that allows code written in one language to call code written in another language. The `libffi' \
7library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. \
8A layer must exist above `libffi' that handles type conversions for values passed between the two languages."
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=679b5c9bdc79a2b93ee574e193e7a7bc"
12
13SRC_URI = "https://github.com/libffi/libffi/releases/download/v${PV}/${BPN}-${PV}.tar.gz \
14 file://not-win32.patch \
15 file://0001-arm-sysv-reverted-clang-VFP-mitigation.patch \
16 "
17SRC_URI[sha256sum] = "540fb721619a6aba3bdeef7d940d8e9e0e6d2c193595bc243241b77ff9e93620"
18UPSTREAM_CHECK_URI = "https://github.com/libffi/libffi/releases/"
19UPSTREAM_CHECK_REGEX = "libffi-(?P<pver>\d+(\.\d+)+)\.tar"
20
21EXTRA_OECONF += "--disable-builddir"
22EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'"
23inherit autotools texinfo multilib_header
24
25do_install_append() {
26 oe_multilib_header ffi.h ffitarget.h
27}
28
29FILES_${PN}-dev += "${libdir}/libffi-${PV}"
30
31# Doesn't compile in MIPS16e mode due to use of hand-written
32# assembly
33MIPS_INSTRUCTION_SET = "mips"
34
35BBCLASSEXTEND = "native nativesdk"
36