summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libffi/libffi_3.3~rc0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libffi/libffi_3.3~rc0.bb')
-rw-r--r--meta/recipes-support/libffi/libffi_3.3~rc0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-support/libffi/libffi_3.3~rc0.bb b/meta/recipes-support/libffi/libffi_3.3~rc0.bb
new file mode 100644
index 0000000000..dadde0b2a0
--- /dev/null
+++ b/meta/recipes-support/libffi/libffi_3.3~rc0.bb
@@ -0,0 +1,36 @@
1SUMMARY = "A portable foreign function interface library"
2HOMEPAGE = "http://sourceware.org/libffi/"
3DESCRIPTION = "The `libffi' library provides a portable, high level programming interface to various calling \
4conventions. This allows a programmer to call any function specified by a call interface description at run \
5time. FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the \
6interface that allows code written in one language to call code written in another language. The `libffi' \
7library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. \
8A layer must exist above `libffi' that handles type conversions for values passed between the two languages."
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=3610bb17683a0089ed64055416b2ae1b"
12
13SRC_URI = "https://github.com/libffi/libffi/releases/download/v3.3-rc0/libffi-3.3-rc0.tar.gz \
14 file://not-win32.patch \
15 "
16SRC_URI[md5sum] = "8d2a82a78faf10a5e53c27d986e8f04e"
17SRC_URI[sha256sum] = "403d67aabf1c05157855ea2b1d9950263fb6316536c8c333f5b9ab1eb2f20ecf"
18
19EXTRA_OECONF += "--disable-builddir"
20EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'"
21inherit autotools texinfo multilib_header
22
23S = "${WORKDIR}/${BPN}-3.3-rc0"
24
25do_install_append() {
26 oe_multilib_header ffi.h
27}
28
29FILES_${PN}-dev += "${libdir}/libffi-${PV}"
30
31# Doesn't compile in MIPS16e mode due to use of hand-written
32# assembly
33MIPS_INSTRUCTION_SET = "mips"
34
35BBCLASSEXTEND = "native nativesdk"
36