summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libevent/libevent_2.1.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libevent/libevent_2.1.12.bb')
-rw-r--r--meta/recipes-support/libevent/libevent_2.1.12.bb23
1 files changed, 15 insertions, 8 deletions
diff --git a/meta/recipes-support/libevent/libevent_2.1.12.bb b/meta/recipes-support/libevent/libevent_2.1.12.bb
index 29e87081d3..25388fb4d7 100644
--- a/meta/recipes-support/libevent/libevent_2.1.12.bb
+++ b/meta/recipes-support/libevent/libevent_2.1.12.bb
@@ -1,27 +1,34 @@
1SUMMARY = "An asynchronous event notification library" 1SUMMARY = "An asynchronous event notification library"
2DESCRIPTION = "A software library that provides asynchronous event \
3notification. The libevent API provides a mechanism to execute a callback \
4function when a specific event occurs on a file descriptor or after a \
5timeout has been reached. libevent also supports callbacks triggered \
6by signals and regular timeouts"
2HOMEPAGE = "http://libevent.org/" 7HOMEPAGE = "http://libevent.org/"
3BUGTRACKER = "https://github.com/libevent/libevent/issues" 8BUGTRACKER = "https://github.com/libevent/libevent/issues"
4SECTION = "libs" 9SECTION = "libs"
5 10
6LICENSE = "BSD & MIT" 11LICENSE = "BSD-3-Clause & MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=17f20574c0b154d12236d5fbe964f549" 12LIC_FILES_CHKSUM = "file://LICENSE;md5=17f20574c0b154d12236d5fbe964f549"
8 13
9SRC_URI = "https://github.com/libevent/libevent/releases/download/release-${PV}-stable/${BP}-stable.tar.gz \ 14SRC_URI = "${GITHUB_BASE_URI}/download/release-${PV}-stable/${BP}-stable.tar.gz \
10 file://Makefile-missing-test-dir.patch \ 15 file://Makefile-missing-test-dir.patch \
11 file://run-ptest \ 16 file://run-ptest \
12 file://0001-test-regress_dns.c-patch-out-tests-that-require-a-wo.patch \ 17 file://0001-test-regress_dns.c-patch-out-tests-that-require-a-wo.patch \
18 file://0002-test-regress.h-Increase-default-timeval-tolerance-50.patch \
19 file://0003-test-mark-util-monotonic_prc_fallback-as-retriable.patch \
20 file://0004-test-retriable-tests-are-marked-failed-only-when-all-a.patch \
13 " 21 "
14 22
15SRC_URI[sha256sum] = "92e6de1be9ec176428fd2367677e61ceffc2ee1cb119035037a27d346b0403bb" 23SRC_URI[sha256sum] = "92e6de1be9ec176428fd2367677e61ceffc2ee1cb119035037a27d346b0403bb"
16 24UPSTREAM_CHECK_REGEX = "releases/tag/release-(?P<pver>.+)-stable"
17UPSTREAM_CHECK_URI = "http://libevent.org/"
18 25
19S = "${WORKDIR}/${BPN}-${PV}-stable" 26S = "${WORKDIR}/${BPN}-${PV}-stable"
20 27
21PACKAGECONFIG ??= "" 28PACKAGECONFIG ??= ""
22PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl" 29PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
23 30
24inherit autotools 31inherit autotools github-releases
25 32
26# Needed for Debian packaging 33# Needed for Debian packaging
27LEAD_SONAME = "libevent-2.1.so" 34LEAD_SONAME = "libevent-2.1.so"
@@ -34,11 +41,11 @@ PACKAGES_DYNAMIC = "^${PN}-.*$"
34python split_libevent_libs () { 41python split_libevent_libs () {
35 do_split_packages(d, '${libdir}', r'^libevent_([a-z]*)-.*\.so\..*', '${PN}-%s', '${SUMMARY} (%s)', prepend=True, allow_links=True) 42 do_split_packages(d, '${libdir}', r'^libevent_([a-z]*)-.*\.so\..*', '${PN}-%s', '${SUMMARY} (%s)', prepend=True, allow_links=True)
36} 43}
37PACKAGESPLITFUNCS_prepend = "split_libevent_libs " 44PACKAGESPLITFUNCS =+ "split_libevent_libs"
38 45
39BBCLASSEXTEND = "native nativesdk" 46BBCLASSEXTEND = "native nativesdk"
40 47
41do_install_append() { 48do_install:append() {
42 rm ${D}${bindir}/event_rpcgen.py 49 rm ${D}${bindir}/event_rpcgen.py
43 rmdir ${D}${bindir} 50 rmdir ${D}${bindir}
44 oe_multilib_header event2/event-config.h 51 oe_multilib_header event2/event-config.h
@@ -50,7 +57,7 @@ do_install_ptest() {
50 do 57 do
51 install -m 0755 $file ${D}${PTEST_PATH}/test 58 install -m 0755 $file ${D}${PTEST_PATH}/test
52 done 59 done
53 60
54 # handle multilib 61 # handle multilib
55 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest 62 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
56} 63}