summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libevent/libevent_2.1.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libevent/libevent_2.1.11.bb')
-rw-r--r--meta/recipes-support/libevent/libevent_2.1.11.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-support/libevent/libevent_2.1.11.bb b/meta/recipes-support/libevent/libevent_2.1.11.bb
new file mode 100644
index 0000000000..1e18f0ab2c
--- /dev/null
+++ b/meta/recipes-support/libevent/libevent_2.1.11.bb
@@ -0,0 +1,46 @@
1SUMMARY = "An asynchronous event notification library"
2HOMEPAGE = "http://libevent.org/"
3BUGTRACKER = "https://github.com/libevent/libevent/issues"
4SECTION = "libs"
5
6LICENSE = "BSD & MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=17f20574c0b154d12236d5fbe964f549"
8
9SRC_URI = " \
10 https://github.com/libevent/libevent/releases/download/release-${PV}-stable/${BP}-stable.tar.gz \
11 file://Makefile-missing-test-dir.patch \
12 file://run-ptest \
13"
14
15SRC_URI[md5sum] = "7f35cfe69b82d879111ec0d7b7b1c531"
16SRC_URI[sha256sum] = "a65bac6202ea8c5609fd5c7e480e6d25de467ea1917c08290c521752f147283d"
17
18UPSTREAM_CHECK_URI = "http://libevent.org/"
19
20S = "${WORKDIR}/${BPN}-${PV}-stable"
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
24
25inherit autotools
26
27# Needed for Debian packaging
28LEAD_SONAME = "libevent-2.1.so"
29
30inherit ptest multilib_header
31
32DEPENDS = "zlib"
33
34BBCLASSEXTEND = "native nativesdk"
35
36do_install_append() {
37 oe_multilib_header event2/event-config.h
38}
39
40do_install_ptest() {
41 install -d ${D}${PTEST_PATH}/test
42 for file in ${B}/test/.libs/regress ${B}/test/.libs/test*
43 do
44 install -m 0755 $file ${D}${PTEST_PATH}/test
45 done
46}