diff options
Diffstat (limited to 'meta/recipes-support/libcap-ng/libcap-ng_0.7.9.bb')
-rw-r--r-- | meta/recipes-support/libcap-ng/libcap-ng_0.7.9.bb | 37 |
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-support/libcap-ng/libcap-ng_0.7.9.bb b/meta/recipes-support/libcap-ng/libcap-ng_0.7.9.bb new file mode 100644 index 0000000000..aff6259db2 --- /dev/null +++ b/meta/recipes-support/libcap-ng/libcap-ng_0.7.9.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | SUMMARY = "An alternate posix capabilities library" | ||
2 | DESCRIPTION = "The libcap-ng library is intended to make programming \ | ||
3 | with POSIX capabilities much easier than the traditional libcap library." | ||
4 | HOMEPAGE = "http://freecode.com/projects/libcap-ng" | ||
5 | SECTION = "base" | ||
6 | LICENSE = "GPLv2+ & LGPLv2.1+" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
8 | file://COPYING.LIB;md5=e3eda01d9815f8d24aae2dbd89b68b06" | ||
9 | |||
10 | SRC_URI = "http://people.redhat.com/sgrubb/libcap-ng/libcap-ng-${PV}.tar.gz \ | ||
11 | file://python.patch" | ||
12 | |||
13 | inherit lib_package autotools python3native | ||
14 | |||
15 | SRC_URI[md5sum] = "2398d695508fab9ce33668c53a89b0e9" | ||
16 | SRC_URI[sha256sum] = "4a1532bcf3731aade40936f6d6a586ed5a66ca4c7455e1338d1f6c3e09221328" | ||
17 | |||
18 | DEPENDS += "swig-native python3" | ||
19 | |||
20 | EXTRA_OECONF += "--with-python --with-python3" | ||
21 | EXTRA_OEMAKE += "PYLIBVER='python${PYTHON_BASEVERSION}${PYTHON_ABI}' PYINC='${STAGING_INCDIR}/${PYLIBVER}'" | ||
22 | |||
23 | PACKAGES += "${PN}-python" | ||
24 | |||
25 | FILES_${PN}-python = "${libdir}/python${PYTHON_BASEVERSION}" | ||
26 | |||
27 | BBCLASSEXTEND = "native" | ||
28 | |||
29 | do_install_append() { | ||
30 | # Moving libcap-ng to base_libdir | ||
31 | if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then | ||
32 | mkdir -p ${D}/${base_libdir}/ | ||
33 | mv -f ${D}${libdir}/libcap-ng.so.* ${D}${base_libdir}/ | ||
34 | relpath=${@os.path.relpath("${base_libdir}", "${libdir}")} | ||
35 | ln -sf ${relpath}/libcap-ng.so.0.0.0 ${D}${libdir}/libcap-ng.so | ||
36 | fi | ||
37 | } | ||