summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb')
-rw-r--r--meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb b/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb
new file mode 100644
index 0000000000..e49b445f57
--- /dev/null
+++ b/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb
@@ -0,0 +1,27 @@
1require libcap-ng.inc
2
3SUMMARY .= " - python"
4
5inherit lib_package autotools python3native
6
7DEPENDS += "libcap-ng python3 swig-native"
8
9S = "${WORKDIR}/libcap-ng-${PV}"
10
11EXTRA_OECONF += "--with-python --with-python3"
12EXTRA_OEMAKE += "PYLIBVER='python${PYTHON_BASEVERSION}${PYTHON_ABI}' PYINC='${STAGING_INCDIR}/${PYLIBVER}'"
13
14do_install_append() {
15 rm -rf ${D}${bindir}
16 rm -rf ${D}${libdir}/.debug
17 rm -f ${D}${libdir}/lib*
18 rm -rf ${D}${libdir}/pkgconfig
19 rm -rf ${D}${datadir}
20 rm -rf ${D}${includedir}
21}
22
23# PACKAGES = "${PN}"
24
25FILES_${PN} = "${libdir}/python${PYTHON_BASEVERSION}"
26FILES_${PN}-dbg =+ "${PYTHON_SITEPACKAGES_DIR}/.debug/_capng.so"
27