summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libbsd/libbsd_0.8.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libbsd/libbsd_0.8.6.bb')
-rw-r--r--meta/recipes-support/libbsd/libbsd_0.8.6.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-support/libbsd/libbsd_0.8.6.bb b/meta/recipes-support/libbsd/libbsd_0.8.6.bb
new file mode 100644
index 0000000000..182543fd42
--- /dev/null
+++ b/meta/recipes-support/libbsd/libbsd_0.8.6.bb
@@ -0,0 +1,50 @@
1# Copyright (C) 2013 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Library of utility functions from BSD systems"
5DESCRIPTION = "This library provides useful functions commonly found on BSD systems, \
6 and lacking on others like GNU systems, thus making it easier to port \
7 projects with strong BSD origins, without needing to embed the same \
8 code over and over again on each project."
9
10HOMEPAGE = "http://libbsd.freedesktop.org/wiki/"
11# There seems to be more licenses used in the code, I don't think we want to list them all here, complete list:
12# OE @ ~/projects/libbsd $ grep ^License: COPYING | sort
13# License: BSD-2-clause
14# License: BSD-2-clause
15# License: BSD-2-clause-NetBSD
16# License: BSD-2-clause-author
17# License: BSD-2-clause-verbatim
18# License: BSD-3-clause
19# License: BSD-3-clause
20# License: BSD-3-clause
21# License: BSD-3-clause-Peter-Wemm
22# License: BSD-3-clause-Regents
23# License: BSD-4-clause-Christopher-G-Demetriou
24# License: BSD-4-clause-Niels-Provos
25# License: BSD-5-clause-Peter-Wemm
26# License: Beerware
27# License: Expat
28# License: ISC
29# License: ISC-Original
30# License: public-domain
31# License: public-domain-Colin-Plumb
32LICENSE = "BSD-4-Clause & ISC & PD"
33LIC_FILES_CHKSUM = "file://COPYING;md5=08fc4e66be4526715dab09c5fba5e9e8"
34SECTION = "libs"
35
36SRC_URI = " \
37 http://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
38 file://0001-src-libbsd-overlay.pc.in-Set-Cflags-to-use-I-instead.patch \
39"
40SRC_URI_append_libc-musl = " \
41 file://0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch \
42 file://0002-Remove-funopen.patch \
43"
44
45SRC_URI[md5sum] = "4ab7bec639af17d0aacb50222b479110"
46SRC_URI[sha256sum] = "467fbf9df1f49af11f7f686691057c8c0a7613ae5a870577bef9155de39f9687"
47
48inherit autotools pkgconfig
49
50BBCLASSEXTEND = "native nativesdk"