summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libbsd/libbsd_0.8.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libbsd/libbsd_0.8.1.bb')
-rw-r--r--meta/recipes-support/libbsd/libbsd_0.8.1.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-support/libbsd/libbsd_0.8.1.bb b/meta/recipes-support/libbsd/libbsd_0.8.1.bb
new file mode 100644
index 0000000000..45420d55e6
--- /dev/null
+++ b/meta/recipes-support/libbsd/libbsd_0.8.1.bb
@@ -0,0 +1,43 @@
1# Copyright (C) 2013 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Library of utility functions from BSD systems"
5DESCRIPTION = "This library provides useful functions commonly found on BSD systems, \
6 and lacking on others like GNU systems, thus making it easier to port \
7 projects with strong BSD origins, without needing to embed the same \
8 code over and over again on each project."
9
10HOMEPAGE = "http://libbsd.freedesktop.org/wiki/"
11# There seems to be more licenses used in the code, I don't think we want to list them all here, complete list:
12# OE @ ~/projects/libbsd $ grep ^License: COPYING | sort
13# License: BSD-2-clause
14# License: BSD-2-clause
15# License: BSD-2-clause-NetBSD
16# License: BSD-2-clause-author
17# License: BSD-2-clause-verbatim
18# License: BSD-3-clause
19# License: BSD-3-clause
20# License: BSD-3-clause
21# License: BSD-3-clause-Peter-Wemm
22# License: BSD-3-clause-Regents
23# License: BSD-4-clause-Christopher-G-Demetriou
24# License: BSD-4-clause-Niels-Provos
25# License: BSD-5-clause-Peter-Wemm
26# License: Beerware
27# License: Expat
28# License: ISC
29# License: ISC-Original
30# License: public-domain
31# License: public-domain-Colin-Plumb
32LICENSE = "BSD-4-Clause & ISC & PD"
33LIC_FILES_CHKSUM = "file://COPYING;md5=145ec05a217d8f879f29cfc5f83084be"
34SECTION = "libs"
35
36SRC_URI = " \
37 http://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
38"
39
40SRC_URI[md5sum] = "f3daff0283af6e30f25d68be2deac4ef"
41SRC_URI[sha256sum] = "adbc8781ad720bce939b689f38a9f0247732a36792147a7c28027c393c2af9b0"
42
43inherit autotools pkgconfig