summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libbsd/libbsd_0.10.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libbsd/libbsd_0.10.0.bb')
-rw-r--r--meta/recipes-support/libbsd/libbsd_0.10.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-support/libbsd/libbsd_0.10.0.bb b/meta/recipes-support/libbsd/libbsd_0.10.0.bb
new file mode 100644
index 0000000000..eaf244a3b7
--- /dev/null
+++ b/meta/recipes-support/libbsd/libbsd_0.10.0.bb
@@ -0,0 +1,41 @@
1# Copyright (C) 2013 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Library of utility functions from BSD systems"
5DESCRIPTION = "This library provides useful functions commonly found on BSD systems, \
6 and lacking on others like GNU systems, thus making it easier to port \
7 projects with strong BSD origins, without needing to embed the same \
8 code over and over again on each project."
9
10HOMEPAGE = "http://libbsd.freedesktop.org/wiki/"
11# There seems to be more licenses used in the code, I don't think we want to list them all here, complete list:
12# OE @ ~/projects/libbsd $ grep ^License: COPYING | sort -u
13# License: BSD-2-clause
14# License: BSD-2-clause-NetBSD
15# License: BSD-2-clause-author
16# License: BSD-2-clause-verbatim
17# License: BSD-3-clause
18# License: BSD-3-clause-author
19# License: BSD-3-clause-John-Birrell
20# License: BSD-3-clause-Regents
21# License: BSD-4-clause-Christopher-G-Demetriou
22# License: BSD-4-clause-Niels-Provos
23# License: BSD-5-clause-Peter-Wemm
24# License: Beerware
25# License: Expat
26# License: ISC
27# License: ISC-Original
28# License: public-domain
29# License: public-domain-Colin-Plumb
30LICENSE = "BSD-4-Clause & ISC & PD"
31LIC_FILES_CHKSUM = "file://COPYING;md5=2120be0173469a06ed185b688e0e1ae0"
32SECTION = "libs"
33
34SRC_URI = "http://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
35
36SRC_URI[md5sum] = "ead96d240d02faa5b921c0aa50c812b5"
37SRC_URI[sha256sum] = "34b8adc726883d0e85b3118fa13605e179a62b31ba51f676136ecb2d0bc1a887"
38
39inherit autotools pkgconfig
40
41BBCLASSEXTEND = "native nativesdk"