summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/js/js_1.7.0+1.8.0rc1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/js/js_1.7.0+1.8.0rc1.bb')
-rw-r--r--meta/recipes-support/js/js_1.7.0+1.8.0rc1.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-support/js/js_1.7.0+1.8.0rc1.bb b/meta/recipes-support/js/js_1.7.0+1.8.0rc1.bb
new file mode 100644
index 0000000000..97cba90d03
--- /dev/null
+++ b/meta/recipes-support/js/js_1.7.0+1.8.0rc1.bb
@@ -0,0 +1,47 @@
1DESCRIPTION = "Spidermonkey: a javascript engine written in C"
2HOMEPAGE = "http://www.mozilla.org/js/spidermonkey/"
3SECTION = "libs"
4
5# the package is licensed under either of the following
6LICENSE = "MPL1.1 | GPLv2+ | LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://jsapi.c;beginline=4;endline=39;md5=347c6bbf4fb4547de1fa5ad830030063"
8PR = "r1"
9
10SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/js/js-1.8.0-rc1.tar.gz \
11 file://link_with_gcc.patch \
12 file://usepic.patch \
13 file://buildcc.patch;striplevel=2 \
14 file://jsautocfg.h \
15 file://configure.ac"
16
17S = "${WORKDIR}/js/src"
18
19# use local autoconf script to generate a usable jsautocfg.h
20# don't bother with automake
21inherit autotools
22
23do_configure_prepend() {
24 cp -f ${WORKDIR}/configure.ac ${S}
25 cp -f ${WORKDIR}/jsautocfg.h ${S}
26}
27
28EXTRA_OEMAKE = "'CC=${CC}' 'LD=${LD}' 'XCFLAGS=${CFLAGS}' 'XLDFLAGS=${LDFLAGS} -Wl,-soname=libjs' \
29 'BUILD_CC=${BUILD_CC}' 'BUILD_CFLAGS=${BUILD_CFLAGS}' 'BUILD_LDFLAGS=${BUILD_LDFLAGS}'"
30
31PARALLEL_MAKE = ""
32
33do_compile() {
34 oe_runmake -f Makefile.ref JS_EDITLINE=1 PREBUILT_CPUCFG=1 BUILD_OPT=1
35}
36
37do_install() {
38 install -d ${D}${libdir}
39 install -d ${D}${includedir}
40 install -d ${D}${includedir}/js
41 oe_libinstall -so -C Linux_All_OPT.OBJ libjs ${D}${libdir}
42 install -m 0644 ${S}/*.h ${D}${includedir}/js
43}
44
45FILES_${PN} = "${libdir}/lib*.so"
46FILES_${PN}-dev = "${includedir} ${libdir}/lib*.a"
47