summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/js/js_1.7.0+1.8.0rc1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/js/js_1.7.0+1.8.0rc1.bb')
-rw-r--r--meta/recipes-support/js/js_1.7.0+1.8.0rc1.bb51
1 files changed, 0 insertions, 51 deletions
diff --git a/meta/recipes-support/js/js_1.7.0+1.8.0rc1.bb b/meta/recipes-support/js/js_1.7.0+1.8.0rc1.bb
deleted file mode 100644
index e32050446c..0000000000
--- a/meta/recipes-support/js/js_1.7.0+1.8.0rc1.bb
+++ /dev/null
@@ -1,51 +0,0 @@
1SUMMARY = "Spidermonkey: a javascript engine written in C"
2HOMEPAGE = "http://www.mozilla.org/js/spidermonkey/"
3SECTION = "libs"
4
5# the package is licensed under either of the following
6LICENSE = "MPL-1 | GPLv2+ | LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://jsapi.c;beginline=4;endline=39;md5=347c6bbf4fb4547de1fa5ad830030063"
8PR = "r4"
9
10SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/js/js-1.8.0-rc1.tar.gz \
11 file://link_with_gcc.patch \
12 file://usepic.patch \
13 file://buildcc.patch;striplevel=2 \
14 file://jsautocfg.h \
15 file://configure.ac"
16
17SRC_URI[md5sum] = "eaad8815dcc66a717ddb87e9724d964e"
18SRC_URI[sha256sum] = "374398699ac3fd802d98d642486cf6b0edc082a119c9c9c499945a0bc73e3413"
19
20S = "${WORKDIR}/js/src"
21
22# use local autoconf script to generate a usable jsautocfg.h
23# don't bother with automake
24inherit autotools-brokensep
25
26do_configure_prepend() {
27 cp -f ${WORKDIR}/configure.ac ${S}
28 cp -f ${WORKDIR}/jsautocfg.h ${S}
29}
30
31EXTRA_OEMAKE = "'CC=${CC}' 'LD=${LD}' 'XCFLAGS=${CFLAGS}' 'XLDFLAGS=${LDFLAGS} -Wl,-soname=libjs' \
32 'BUILD_CC=${BUILD_CC}' 'BUILD_CFLAGS=${BUILD_CFLAGS}' 'BUILD_LDFLAGS=${BUILD_LDFLAGS}'"
33
34PARALLEL_MAKE = ""
35
36do_compile() {
37 oe_runmake -f Makefile.ref JS_EDITLINE=1 PREBUILT_CPUCFG=1 BUILD_OPT=1
38}
39
40do_install() {
41 install -d ${D}${libdir}
42 install -d ${D}${includedir}
43 install -d ${D}${includedir}/js
44 oe_libinstall -so -C Linux_All_OPT.OBJ libjs ${D}${libdir}
45 install -m 0644 ${S}/*.h ${D}${includedir}/js
46 install -m 0644 ${S}/jsproto.tbl ${D}${includedir}/js
47}
48
49FILES_SOLIBSDEV = ""
50FILES_${PN} = "${libdir}/lib*.so"
51