summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gpgme/gpgme_1.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gpgme/gpgme_1.6.0.bb')
-rw-r--r--meta/recipes-support/gpgme/gpgme_1.6.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-support/gpgme/gpgme_1.6.0.bb b/meta/recipes-support/gpgme/gpgme_1.6.0.bb
new file mode 100644
index 0000000000..987d19bc4e
--- /dev/null
+++ b/meta/recipes-support/gpgme/gpgme_1.6.0.bb
@@ -0,0 +1,39 @@
1SUMMARY = "High-level GnuPG encryption/signing API"
2DESCRIPTION = "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management"
3HOMEPAGE = "http://www.gnupg.org/gpgme.html"
4BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
5
6LICENSE = "GPLv2+ & LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://COPYING.LESSER;md5=bbb461211a33b134d42ed5ee802b37ff \
9 file://src/gpgme.h.in;endline=23;md5=5027eec93a996272a9a0a6a86cf35775 \
10 file://src/engine.h;endline=22;md5=4b6d8ba313d9b564cc4d4cfb1640af9d"
11
12SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/${BP}.tar.bz2 \
13 file://gpgme.pc \
14 file://pkgconfig.patch \
15 "
16
17SRC_URI[md5sum] = "60d730d22e8065fd5de309e8b98e304b"
18SRC_URI[sha256sum] = "b09de4197ac280b102080e09eaec6211d081efff1963bf7821cf8f4f9916099d"
19
20DEPENDS = "libgpg-error libassuan"
21
22BINCONFIG = "${bindir}/gpgme-config"
23
24inherit autotools texinfo binconfig-disabled pkgconfig
25
26PACKAGES =+ "${PN}-pthread"
27FILES_${PN}-pthread = "${libdir}/libgpgme-pthread.so.*"
28FILES_${PN}-dev += "${datadir}/common-lisp/source/gpgme/*"
29
30do_configure_prepend () {
31 # Else these could be used in preference to those in aclocal-copy
32 rm -f ${S}/m4/gpg-error.m4
33 rm -f ${S}/m4/libassuan.m4
34}
35
36do_install_append () {
37 install -d ${D}${libdir}/pkgconfig
38 install -m 0644 ${WORKDIR}/gpgme.pc ${D}${libdir}/pkgconfig/
39}