summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gpgme/gpgme_1.5.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gpgme/gpgme_1.5.4.bb')
-rw-r--r--meta/recipes-support/gpgme/gpgme_1.5.4.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-support/gpgme/gpgme_1.5.4.bb b/meta/recipes-support/gpgme/gpgme_1.5.4.bb
new file mode 100644
index 0000000000..1598377d6e
--- /dev/null
+++ b/meta/recipes-support/gpgme/gpgme_1.5.4.bb
@@ -0,0 +1,39 @@
1SUMMARY = "High-level GnuPG encryption/signing API"
2DESCRIPTION = "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management"
3HOMEPAGE = "http://www.gnupg.org/gpgme.html"
4BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
5
6LICENSE = "GPLv2+ & LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://COPYING.LESSER;md5=bbb461211a33b134d42ed5ee802b37ff \
9 file://src/gpgme.h.in;endline=23;md5=71ba2ae8d6ca034ed10bd099a8cf473c \
10 file://src/engine.h;endline=22;md5=4b6d8ba313d9b564cc4d4cfb1640af9d"
11
12SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/${BP}.tar.bz2 \
13 file://gpgme.pc \
14 file://pkgconfig.patch \
15 "
16
17SRC_URI[md5sum] = "feafa03ea064e1d1dc11bc2b88404623"
18SRC_URI[sha256sum] = "bb38c0ec8815c9e94e6047b484984808a8dad9d6bec8df33dc5339fd55ffea6c"
19
20DEPENDS = "libgpg-error libassuan"
21
22BINCONFIG = "${bindir}/gpgme-config"
23
24inherit autotools texinfo binconfig-disabled pkgconfig
25
26PACKAGES =+ "${PN}-pthread"
27FILES_${PN}-pthread = "${libdir}/libgpgme-pthread.so.*"
28FILES_${PN}-dev += "${datadir}/common-lisp/source/gpgme/*"
29
30do_configure_prepend () {
31 # Else these could be used in preference to those in aclocal-copy
32 rm -f ${S}/m4/gpg-error.m4
33 rm -f ${S}/m4/libassuan.m4
34}
35
36do_install_append () {
37 install -d ${D}${libdir}/pkgconfig
38 install -m 0644 ${WORKDIR}/gpgme.pc ${D}${libdir}/pkgconfig/
39}