summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gpgme/gpgme_1.4.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gpgme/gpgme_1.4.3.bb')
-rw-r--r--meta/recipes-support/gpgme/gpgme_1.4.3.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-support/gpgme/gpgme_1.4.3.bb b/meta/recipes-support/gpgme/gpgme_1.4.3.bb
new file mode 100644
index 0000000000..aacd92383c
--- /dev/null
+++ b/meta/recipes-support/gpgme/gpgme_1.4.3.bb
@@ -0,0 +1,30 @@
1SUMMARY = "High-level GnuPG encryption/signing API"
2DESCRIPTION = "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management"
3HOMEPAGE = "http://www.gnupg.org/gpgme.html"
4BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
5
6LICENSE = "GPLv2+ & LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://COPYING.LESSER;md5=bbb461211a33b134d42ed5ee802b37ff \
9 file://src/gpgme.h.in;endline=23;md5=dccb4bb624011e36513c61ef0422d054 \
10 file://src/engine.h;endline=22;md5=4b6d8ba313d9b564cc4d4cfb1640af9d"
11
12SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${PV}.tar.bz2 \
13 file://disable_gpgconf_check.patch"
14
15SRC_URI[md5sum] = "334e524cffa8af4e2f43ae8afe585672"
16SRC_URI[sha256sum] = "2d1cc12411753752d9c5b9037e6fd3fd363517af720154768cc7b46b60120496"
17
18DEPENDS = "libgpg-error libassuan ${PTH}"
19PTH_libc-uclibc = "npth"
20PTH = "pth"
21
22EXTRA_OECONF = "--with-pth=${STAGING_DIR_HOST} --without-pth-test \
23 --with-gpg=${bindir}/gpg --without-gpgsm"
24
25inherit autotools binconfig
26
27PACKAGES =+ "${PN}-pth ${PN}-pthread"
28FILES_${PN}-pth = "${libdir}/libgpgme-pth.so.*"
29FILES_${PN}-pthread = "${libdir}/libgpgme-pthread.so.*"
30FILES_${PN}-dev += "${datadir}/common-lisp/source/gpgme/*"