summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gpgme/gpgme_1.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gpgme/gpgme_1.3.0.bb')
-rw-r--r--meta/recipes-support/gpgme/gpgme_1.3.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-support/gpgme/gpgme_1.3.0.bb b/meta/recipes-support/gpgme/gpgme_1.3.0.bb
new file mode 100644
index 0000000000..1c665b5ea4
--- /dev/null
+++ b/meta/recipes-support/gpgme/gpgme_1.3.0.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management"
2HOMEPAGE = "http://www.gnupg.org/gpgme.html"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4
5LICENSE = "GPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://COPYING.LESSER;md5=bbb461211a33b134d42ed5ee802b37ff \
8 file://src/gpgme.h;endline=23;md5=2775a99d3dd524c4f848ff1c59093038 \
9 file://src/engine.h;endline=22;md5=e96acfaab1cff82dd8fbefddd2f5c436"
10
11SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${PV}.tar.bz2 \
12 file://disable_gpgconf_check.patch;patch=1;pnum=1"
13DEPENDS = "libgpg-error libassuan pth"
14PR = "r0"
15
16EXTRA_OECONF = "--with-pth=${STAGING_DIR_HOST} --without-pth-test \
17 --with-gpg=${bindir}/gpg --without-gpgsm"
18
19inherit autotools binconfig
20
21PACKAGES =+ "${PN}-pth ${PN}-pthread"
22FILES_${PN}-pth = "${libdir}/libgpgme-pth.so.*"
23FILES_${PN}-pthread = "${libdir}/libgpgme-pthread.so.*"
24FILES_${PN} = "${libdir}/libgpgme.so.*"
25FILES_${PN}-dev += "${bindir}/gpgme-config"