summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnutls/gnutls_3.6.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gnutls/gnutls_3.6.7.bb')
-rw-r--r--meta/recipes-support/gnutls/gnutls_3.6.7.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-support/gnutls/gnutls_3.6.7.bb b/meta/recipes-support/gnutls/gnutls_3.6.7.bb
new file mode 100644
index 0000000000..e05dc2b57d
--- /dev/null
+++ b/meta/recipes-support/gnutls/gnutls_3.6.7.bb
@@ -0,0 +1,63 @@
1SUMMARY = "GNU Transport Layer Security Library"
2HOMEPAGE = "http://www.gnu.org/software/gnutls/"
3BUGTRACKER = "https://savannah.gnu.org/support/?group=gnutls"
4
5LICENSE = "GPLv3+ & LGPLv2.1+"
6LICENSE_${PN} = "LGPLv2.1+"
7LICENSE_${PN}-xx = "LGPLv2.1+"
8LICENSE_${PN}-bin = "GPLv3+"
9LICENSE_${PN}-openssl = "GPLv3+"
10
11LIC_FILES_CHKSUM = "file://LICENSE;md5=71391c8e0c1cfe68077e7fce3b586283 \
12 file://doc/COPYING;md5=c678957b0c8e964aa6c70fd77641a71e \
13 file://doc/COPYING.LESSER;md5=a6f89e2100d9b6cdffcea4f398e37343"
14
15DEPENDS = "nettle gmp virtual/libiconv libunistring"
16DEPENDS_append_libc-musl = " argp-standalone"
17
18SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
19
20SRC_URI = "https://www.gnupg.org/ftp/gcrypt/gnutls/v${SHRT_VER}/gnutls-${PV}.tar.xz \
21 file://arm_eabi.patch \
22"
23
24SRC_URI[md5sum] = "c4ac669c500df939d4fbfea722367929"
25SRC_URI[sha256sum] = "5b3409ad5aaf239808730d1ee12fdcd148c0be00262c7edf157af655a8a188e2"
26
27inherit autotools texinfo pkgconfig gettext lib_package gtk-doc
28
29PACKAGECONFIG ??= "libidn"
30
31# You must also have CONFIG_SECCOMP enabled in the kernel for
32# seccomp to work.
33PACKAGECONFIG[seccomp] = "ac_cv_libseccomp=yes,ac_cv_libseccomp=no,libseccomp"
34PACKAGECONFIG[libidn] = "--with-idn,--without-idn,libidn2"
35PACKAGECONFIG[libtasn1] = "--with-included-libtasn1=no,--with-included-libtasn1,libtasn1"
36PACKAGECONFIG[p11-kit] = "--with-p11-kit,--without-p11-kit,p11-kit"
37PACKAGECONFIG[tpm] = "--with-tpm,--without-tpm,trousers"
38
39EXTRA_OECONF = " \
40 --enable-doc \
41 --disable-libdane \
42 --disable-guile \
43 --disable-rpath \
44 --enable-local-libopts \
45 --enable-openssl-compatibility \
46 --with-libpthread-prefix=${STAGING_DIR_HOST}${prefix} \
47"
48
49LDFLAGS_append_libc-musl = " -largp"
50
51do_configure_prepend() {
52 for dir in . lib; do
53 rm -f ${dir}/aclocal.m4 ${dir}/m4/libtool.m4 ${dir}/m4/lt*.m4
54 done
55}
56
57PACKAGES =+ "${PN}-openssl ${PN}-xx"
58
59FILES_${PN}-dev += "${bindir}/gnutls-cli-debug"
60FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
61FILES_${PN}-xx = "${libdir}/libgnutlsxx.so.*"
62
63BBCLASSEXTEND = "native nativesdk"