summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnupg/gnupg_2.2.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gnupg/gnupg_2.2.5.bb')
-rw-r--r--meta/recipes-support/gnupg/gnupg_2.2.5.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_2.2.5.bb b/meta/recipes-support/gnupg/gnupg_2.2.5.bb
new file mode 100644
index 0000000000..f6d5dad254
--- /dev/null
+++ b/meta/recipes-support/gnupg/gnupg_2.2.5.bb
@@ -0,0 +1,50 @@
1SUMMARY = "GNU Privacy Guard - encryption and signing tools (2.x)"
2HOMEPAGE = "http://www.gnupg.org/"
3LICENSE = "GPLv3 & LGPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=189af8afca6d6075ba6c9e0aa8077626 \
5 file://COPYING.LGPL3;md5=a2b6bf2cb38ee52619e60f30a1fc7257"
6
7DEPENDS = "npth libassuan libksba zlib bzip2 readline libgcrypt"
8
9inherit autotools gettext texinfo pkgconfig
10
11UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
12SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
13 file://0001-Use-pkg-config-to-find-pth-instead-of-pth-config.patch \
14 file://0002-use-pkgconfig-instead-of-npth-config.patch \
15 file://0003-dirmngr-uses-libgpg-error.patch \
16 file://0004-autogen.sh-fix-find-version-for-beta-checking.patch \
17 "
18SRC_URI_append_class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch"
19
20
21SRC_URI[md5sum] = "567cd2d41fa632903066fde73d2005cb"
22SRC_URI[sha256sum] = "3fa189a32d4fb62147874eb1389047c267d9ba088f57ab521cb0df46f08aef57"
23
24EXTRA_OECONF = "--disable-ldap \
25 --disable-ccid-driver \
26 --with-zlib=${STAGING_LIBDIR}/.. \
27 --with-bzip2=${STAGING_LIBDIR}/.. \
28 --with-readline=${STAGING_LIBDIR}/.. \
29 --enable-gpg-is-gpg2 \
30 "
31RRECOMMENDS_${PN} = "pinentry"
32
33do_configure_prepend () {
34 # Else these could be used in prefernce to those in aclocal-copy
35 rm -f ${S}/m4/gpg-error.m4
36 rm -f ${S}/m4/libassuan.m4
37 rm -f ${S}/m4/ksba.m4
38 rm -f ${S}/m4/libgcrypt.m4
39}
40
41do_install_append() {
42 ln -sf gpg2 ${D}${bindir}/gpg
43 ln -sf gpgv2 ${D}${bindir}/gpgv
44}
45
46PACKAGECONFIG ??= "gnutls"
47PACKAGECONFIG[gnutls] = "--enable-gnutls, --disable-gnutls, gnutls"
48PACKAGECONFIG[sqlite3] = "--enable-sqlite, --disable-sqlite, sqlite3"
49
50BBCLASSEXTEND = "native"