summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnupg/gnupg_2.2.27.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gnupg/gnupg_2.2.27.bb')
-rw-r--r--meta/recipes-support/gnupg/gnupg_2.2.27.bb80
1 files changed, 0 insertions, 80 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_2.2.27.bb b/meta/recipes-support/gnupg/gnupg_2.2.27.bb
deleted file mode 100644
index 8b5fc9983a..0000000000
--- a/meta/recipes-support/gnupg/gnupg_2.2.27.bb
+++ /dev/null
@@ -1,80 +0,0 @@
1SUMMARY = "GNU Privacy Guard - encryption and signing tools (2.x)"
2HOMEPAGE = "http://www.gnupg.org/"
3LICENSE = "GPLv3 & LGPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=189af8afca6d6075ba6c9e0aa8077626 \
5 file://COPYING.LGPL3;md5=a2b6bf2cb38ee52619e60f30a1fc7257"
6
7DEPENDS = "npth libassuan libksba zlib bzip2 readline libgcrypt"
8
9inherit autotools gettext texinfo pkgconfig
10
11UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
12SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
13 file://0001-Use-pkg-config-to-find-pth-instead-of-pth-config.patch \
14 file://0002-use-pkgconfig-instead-of-npth-config.patch \
15 file://0003-dirmngr-uses-libgpg-error.patch \
16 file://0004-autogen.sh-fix-find-version-for-beta-checking.patch \
17 file://0001-Woverride-init-is-not-needed-with-gcc-9.patch \
18 "
19SRC_URI_append_class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch \
20 file://relocate.patch"
21SRC_URI_append_class-nativesdk = " file://relocate.patch"
22
23SRC_URI[sha256sum] = "34e60009014ea16402069136e0a5f63d9b65f90096244975db5cea74b3d02399"
24
25EXTRA_OECONF = "--disable-ldap \
26 --disable-ccid-driver \
27 --with-zlib=${STAGING_LIBDIR}/.. \
28 --with-bzip2=${STAGING_LIBDIR}/.. \
29 --with-readline=${STAGING_LIBDIR}/.. \
30 --enable-gpg-is-gpg2 \
31 "
32
33# A minimal package containing just enough to run gpg+gpgagent (E.g. use gpgme in opkg)
34PACKAGES =+ "${PN}-gpg"
35FILES_${PN}-gpg = " \
36 ${bindir}/gpg \
37 ${bindir}/gpg2 \
38 ${bindir}/gpg-agent \
39"
40
41# Normal package (gnupg) should depend on minimal package (gnupg-gpg)
42# to ensure all tools are included. This is done only in non-native
43# builds. Native builds don't have sub-packages, so appending RDEPENDS
44# in this case breaks recipe parsing.
45RDEPENDS_${PN} += "${@ "" if ("native" in d.getVar("PN")) else (d.getVar("PN") + "-gpg")}"
46
47RRECOMMENDS_${PN} = "pinentry"
48
49do_configure_prepend () {
50 # Else these could be used in prefernce to those in aclocal-copy
51 rm -f ${S}/m4/gpg-error.m4
52 rm -f ${S}/m4/libassuan.m4
53 rm -f ${S}/m4/ksba.m4
54 rm -f ${S}/m4/libgcrypt.m4
55}
56
57do_install_append() {
58 ln -sf gpg2 ${D}${bindir}/gpg
59 ln -sf gpgv2 ${D}${bindir}/gpgv
60}
61
62do_install_append_class-native() {
63 create_wrappers ${STAGING_BINDIR_NATIVE}
64}
65
66do_install_append_class-nativesdk() {
67 create_wrappers ${SDKPATHNATIVE}${bindir_nativesdk}
68}
69
70create_wrappers() {
71 for i in gpg2 gpgconf gpg-agent gpg-connect-agent; do
72 create_wrapper ${D}${bindir}/$i GNUPG_BINDIR=$1
73 done
74}
75
76PACKAGECONFIG ??= "gnutls"
77PACKAGECONFIG[gnutls] = "--enable-gnutls, --disable-gnutls, gnutls"
78PACKAGECONFIG[sqlite3] = "--enable-sqlite, --disable-sqlite, sqlite3"
79
80BBCLASSEXTEND = "native nativesdk"