summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnupg/gnupg_2.2.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gnupg/gnupg_2.2.20.bb')
-rw-r--r--meta/recipes-support/gnupg/gnupg_2.2.20.bb81
1 files changed, 0 insertions, 81 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_2.2.20.bb b/meta/recipes-support/gnupg/gnupg_2.2.20.bb
deleted file mode 100644
index f754573c88..0000000000
--- a/meta/recipes-support/gnupg/gnupg_2.2.20.bb
+++ /dev/null
@@ -1,81 +0,0 @@
1SUMMARY = "GNU Privacy Guard - encryption and signing tools (2.x)"
2HOMEPAGE = "http://www.gnupg.org/"
3LICENSE = "GPLv3 & LGPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=189af8afca6d6075ba6c9e0aa8077626 \
5 file://COPYING.LGPL3;md5=a2b6bf2cb38ee52619e60f30a1fc7257"
6
7DEPENDS = "npth libassuan libksba zlib bzip2 readline libgcrypt"
8
9inherit autotools gettext texinfo pkgconfig
10
11UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
12SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
13 file://0001-Use-pkg-config-to-find-pth-instead-of-pth-config.patch \
14 file://0002-use-pkgconfig-instead-of-npth-config.patch \
15 file://0003-dirmngr-uses-libgpg-error.patch \
16 file://0004-autogen.sh-fix-find-version-for-beta-checking.patch \
17 file://0001-Woverride-init-is-not-needed-with-gcc-9.patch \
18 "
19SRC_URI_append_class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch \
20 file://relocate.patch"
21SRC_URI_append_class-nativesdk = " file://relocate.patch"
22
23SRC_URI[md5sum] = "4ff88920cf52b35db0dedaee87bdbbb1"
24SRC_URI[sha256sum] = "04a7c9d48b74c399168ee8270e548588ddbe52218c337703d7f06373d326ca30"
25
26EXTRA_OECONF = "--disable-ldap \
27 --disable-ccid-driver \
28 --with-zlib=${STAGING_LIBDIR}/.. \
29 --with-bzip2=${STAGING_LIBDIR}/.. \
30 --with-readline=${STAGING_LIBDIR}/.. \
31 --enable-gpg-is-gpg2 \
32 "
33
34# A minimal package containing just enough to run gpg+gpgagent (E.g. use gpgme in opkg)
35PACKAGES =+ "${PN}-gpg"
36FILES_${PN}-gpg = " \
37 ${bindir}/gpg \
38 ${bindir}/gpg2 \
39 ${bindir}/gpg-agent \
40"
41
42# Normal package (gnupg) should depend on minimal package (gnupg-gpg)
43# to ensure all tools are included. This is done only in non-native
44# builds. Native builds don't have sub-packages, so appending RDEPENDS
45# in this case breaks recipe parsing.
46RDEPENDS_${PN} += "${@ "" if ("native" in d.getVar("PN")) else (d.getVar("PN") + "-gpg")}"
47
48RRECOMMENDS_${PN} = "pinentry"
49
50do_configure_prepend () {
51 # Else these could be used in prefernce to those in aclocal-copy
52 rm -f ${S}/m4/gpg-error.m4
53 rm -f ${S}/m4/libassuan.m4
54 rm -f ${S}/m4/ksba.m4
55 rm -f ${S}/m4/libgcrypt.m4
56}
57
58do_install_append() {
59 ln -sf gpg2 ${D}${bindir}/gpg
60 ln -sf gpgv2 ${D}${bindir}/gpgv
61}
62
63do_install_append_class-native() {
64 create_wrappers ${STAGING_BINDIR_NATIVE}
65}
66
67do_install_append_class-nativesdk() {
68 create_wrappers ${SDKPATHNATIVE}${bindir_nativesdk}
69}
70
71create_wrappers() {
72 for i in gpg2 gpgconf gpg-agent gpg-connect-agent; do
73 create_wrapper ${D}${bindir}/$i GNUPG_BINDIR=$1
74 done
75}
76
77PACKAGECONFIG ??= "gnutls"
78PACKAGECONFIG[gnutls] = "--enable-gnutls, --disable-gnutls, gnutls"
79PACKAGECONFIG[sqlite3] = "--enable-sqlite, --disable-sqlite, sqlite3"
80
81BBCLASSEXTEND = "native nativesdk"