diff options
Diffstat (limited to 'meta/recipes-support/gnupg/gnupg_2.2.16.bb')
-rw-r--r-- | meta/recipes-support/gnupg/gnupg_2.2.16.bb | 56 |
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_2.2.16.bb b/meta/recipes-support/gnupg/gnupg_2.2.16.bb new file mode 100644 index 0000000000..cb7c6c5c62 --- /dev/null +++ b/meta/recipes-support/gnupg/gnupg_2.2.16.bb | |||
@@ -0,0 +1,56 @@ | |||
1 | SUMMARY = "GNU Privacy Guard - encryption and signing tools (2.x)" | ||
2 | HOMEPAGE = "http://www.gnupg.org/" | ||
3 | LICENSE = "GPLv3 & LGPLv3" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=189af8afca6d6075ba6c9e0aa8077626 \ | ||
5 | file://COPYING.LGPL3;md5=a2b6bf2cb38ee52619e60f30a1fc7257" | ||
6 | |||
7 | DEPENDS = "npth libassuan libksba zlib bzip2 readline libgcrypt" | ||
8 | |||
9 | inherit autotools gettext texinfo pkgconfig | ||
10 | |||
11 | UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html" | ||
12 | SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \ | ||
13 | file://0001-Use-pkg-config-to-find-pth-instead-of-pth-config.patch \ | ||
14 | file://0002-use-pkgconfig-instead-of-npth-config.patch \ | ||
15 | file://0003-dirmngr-uses-libgpg-error.patch \ | ||
16 | file://0004-autogen.sh-fix-find-version-for-beta-checking.patch \ | ||
17 | file://0001-Woverride-init-is-not-needed-with-gcc-9.patch \ | ||
18 | " | ||
19 | SRC_URI_append_class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch \ | ||
20 | file://relocate.patch" | ||
21 | |||
22 | |||
23 | SRC_URI[md5sum] = "d90e186df1c06845880ea58a318f070b" | ||
24 | SRC_URI[sha256sum] = "6cbe8d454bf5dc204621eed3016d721b66298fa95363395bb8eeceb1d2fd14cb" | ||
25 | |||
26 | EXTRA_OECONF = "--disable-ldap \ | ||
27 | --disable-ccid-driver \ | ||
28 | --with-zlib=${STAGING_LIBDIR}/.. \ | ||
29 | --with-bzip2=${STAGING_LIBDIR}/.. \ | ||
30 | --with-readline=${STAGING_LIBDIR}/.. \ | ||
31 | --enable-gpg-is-gpg2 \ | ||
32 | " | ||
33 | RRECOMMENDS_${PN} = "pinentry" | ||
34 | |||
35 | do_configure_prepend () { | ||
36 | # Else these could be used in prefernce to those in aclocal-copy | ||
37 | rm -f ${S}/m4/gpg-error.m4 | ||
38 | rm -f ${S}/m4/libassuan.m4 | ||
39 | rm -f ${S}/m4/ksba.m4 | ||
40 | rm -f ${S}/m4/libgcrypt.m4 | ||
41 | } | ||
42 | |||
43 | do_install_append() { | ||
44 | ln -sf gpg2 ${D}${bindir}/gpg | ||
45 | ln -sf gpgv2 ${D}${bindir}/gpgv | ||
46 | } | ||
47 | |||
48 | do_install_append_class-native() { | ||
49 | create_wrapper ${D}${bindir}/gpg2 GNUPG_BINDIR=${STAGING_BINDIR_NATIVE} | ||
50 | } | ||
51 | |||
52 | PACKAGECONFIG ??= "gnutls" | ||
53 | PACKAGECONFIG[gnutls] = "--enable-gnutls, --disable-gnutls, gnutls" | ||
54 | PACKAGECONFIG[sqlite3] = "--enable-sqlite, --disable-sqlite, sqlite3" | ||
55 | |||
56 | BBCLASSEXTEND = "native" | ||