summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnupg/gnupg_1.4.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gnupg/gnupg_1.4.7.bb')
-rw-r--r--meta/recipes-support/gnupg/gnupg_1.4.7.bb92
1 files changed, 92 insertions, 0 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_1.4.7.bb b/meta/recipes-support/gnupg/gnupg_1.4.7.bb
new file mode 100644
index 0000000000..daea5aad2a
--- /dev/null
+++ b/meta/recipes-support/gnupg/gnupg_1.4.7.bb
@@ -0,0 +1,92 @@
1DESCRIPTION = "gnupg - GNU privacy guard"
2HOMEPAGE = "http://www.gnupg.org/"
3DEPENDS = "zlib bzip2 readline"
4SECTION = "console/utils"
5
6LICENSE = "GPLv2"
7
8LIC_FILES_CHKSUM = "file://COPYING;md5="
9
10PR = "r4"
11
12SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-${PV}.tar.bz2 \
13 file://long-long-thumb.patch \
14 file://mips_gcc4.4.patch"
15
16SRC_URI[md5sum] = "dcf7ed712997888d616e029637bfc303"
17SRC_URI[sha256sum] = "a2907f4432d67894e425e48ae85785dd60ecb01658c9682bcd96f5e91043bb38"
18
19S = "${WORKDIR}/gnupg-${PV}"
20
21inherit autotools gettext
22
23# --with-egd-socket=NAME use NAME for the EGD socket
24# --with-photo-viewer=FIXED_VIEWER set a fixed photo ID viewer
25# --with-included-zlib use the zlib code included here
26# --with-capabilities use linux capabilities default=no
27# --with-mailprog=NAME use "NAME -t" for mail transport
28# --with-libiconv-prefix[=DIR] search for libiconv in DIR/include and DIR/lib
29# --without-libiconv-prefix don't search for libiconv in includedir and libdir
30# --with-included-gettext use the GNU gettext library included here
31# --with-libintl-prefix[=DIR] search for libintl in DIR/include and DIR/lib
32# --without-libintl-prefix don't search for libintl in includedir and libdir
33# --without-readline do not support fancy command line editing
34# --with-included-regex use the included GNU regex library
35# --with-zlib=DIR use libz in DIR
36# --with-bzip2=DIR look for bzip2 in DIR
37# --enable-static-rnd=egd|unix|linux|auto
38# --disable-dev-random disable the use of dev random
39# --disable-asm do not use assembler modules
40# --enable-m-guard enable memory guard facility
41# --enable-selinux-support
42# enable SELinux support
43# --disable-card-support disable OpenPGP card support
44# --disable-gnupg-iconv disable the new iconv code
45# --enable-backsigs enable the experimental backsigs code
46# --enable-minimal build the smallest gpg binary possible
47# --disable-rsa disable the RSA public key algorithm
48# --disable-idea disable the IDEA cipher
49# --disable-cast5 disable the CAST5 cipher
50# --disable-blowfish disable the BLOWFISH cipher
51# --disable-aes disable the AES, AES192, and AES256 ciphers
52# --disable-twofish disable the TWOFISH cipher
53# --disable-sha256 disable the SHA-256 digest
54# --disable-sha512 disable the SHA-384 and SHA-512 digests
55# --disable-bzip2 disable the BZIP2 compression algorithm
56# --disable-exec disable all external program execution
57# --disable-photo-viewers disable photo ID viewers
58# --disable-keyserver-helpers disable all external keyserver support
59# --disable-ldap disable LDAP keyserver interface
60# --disable-hkp disable HKP keyserver interface
61# --disable-http disable HTTP key fetching interface
62# --disable-finger disable Finger key fetching interface
63# --disable-mailto disable email keyserver interface
64# --disable-keyserver-path disable the exec-path option for keyserver helpers
65# --enable-key-cache=SIZE Set key cache to SIZE (default 4096)
66# --disable-largefile omit support for large files
67# --disable-dns-srv disable the use of DNS SRV in HKP and HTTP
68# --disable-nls do not use Native Language Support
69# --disable-regex do not handle regular expressions in trust sigs
70
71EXTRA_OECONF = "--disable-ldap \
72 --with-zlib=${STAGING_LIBDIR}/.. \
73 --with-bzip2=${STAGING_LIBDIR}/.. \
74 --disable-selinux-support \
75 --with-readline=${STAGING_LIBDIR}/.. \
76 ac_cv_sys_symbol_underscore=yes"
77
78do_install () {
79 autotools_do_install
80 install -d ${D}${docdir}/${PN}
81 mv ${D}${datadir}/${PN}/* ${D}/${docdir}/${PN}/ || :
82 mv ${D}${prefix}/doc/* ${D}/${docdir}/${PN}/ || :
83}
84
85# split out gpgv from main package
86RDEPENDS_${PN} = "gpgv"
87PACKAGES =+ "gpgv"
88FILES_gpgv = "${bindir}/gpgv"
89
90# Exclude debug files from the main packages
91FILES_${PN} = "${bindir}/* ${datadir}/${PN} ${libexecdir}/${PN}/*"
92FILES_${PN}-dbg += "${libexecdir}/${PN}/.debug"