summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gdbm/gdbm_1.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gdbm/gdbm_1.11.bb')
-rw-r--r--meta/recipes-support/gdbm/gdbm_1.11.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-support/gdbm/gdbm_1.11.bb b/meta/recipes-support/gdbm/gdbm_1.11.bb
new file mode 100644
index 0000000000..adf8c5bd38
--- /dev/null
+++ b/meta/recipes-support/gdbm/gdbm_1.11.bb
@@ -0,0 +1,43 @@
1SUMMARY = "Key/value database library with extensible hashing"
2HOMEPAGE = "http://www.gnu.org/software/gdbm/"
3SECTION = "libs"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=241da1b9fe42e642cbb2c24d5e0c4d24"
6
7
8SRC_URI = "${GNU_MIRROR}/gdbm/gdbm-${PV}.tar.gz \
9 file://run-ptest \
10 file://ptest.patch \
11 "
12
13SRC_URI[md5sum] = "72c832680cf0999caedbe5b265c8c1bd"
14SRC_URI[sha256sum] = "8d912f44f05d0b15a4a5d96a76f852e905d051bb88022fcdfd98b43be093e3c3"
15
16inherit autotools gettext texinfo lib_package ptest
17
18# Needed for dbm python module
19EXTRA_OECONF = "-enable-libgdbm-compat"
20
21# Stop presence of dbm/nbdm on the host contaminating builds
22CACHED_CONFIGUREVARS += "ac_cv_lib_ndbm_main=no ac_cv_lib_dbm_main=no"
23
24BBCLASSEXTEND = "native nativesdk"
25
26do_install_append () {
27 # Create a symlink to ndbm.h and gdbm.h in include/gdbm to let other packages to find
28 # these headers
29 install -d ${D}${includedir}/gdbm
30 ln -sf ../ndbm.h ${D}/${includedir}/gdbm/ndbm.h
31 ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h
32}
33
34RDEPENDS_${PN}-ptest += "diffutils"
35
36do_compile_ptest() {
37 oe_runmake -C tests buildtests
38}
39
40PACKAGES =+ "${PN}-compat \
41 "
42FILES_${PN}-compat = "${libdir}/libgdbm_compat${SOLIBS} \
43 "