summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/enchant/enchant2_2.2.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/enchant/enchant2_2.2.8.bb')
-rw-r--r--meta/recipes-support/enchant/enchant2_2.2.8.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-support/enchant/enchant2_2.2.8.bb b/meta/recipes-support/enchant/enchant2_2.2.8.bb
new file mode 100644
index 0000000000..4ddbe55da5
--- /dev/null
+++ b/meta/recipes-support/enchant/enchant2_2.2.8.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Enchant Spell checker API Library"
2SECTION = "libs"
3HOMEPAGE = "https://abiword.github.io/enchant/"
4LICENSE = "LGPLv2.1+"
5LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7"
6
7DEPENDS = "glib-2.0"
8
9inherit autotools pkgconfig
10
11SRC_URI = "https://github.com/AbiWord/enchant/releases/download/v${PV}/enchant-${PV}.tar.gz"
12SRC_URI[md5sum] = "c7b9d6a392ecb8758e499f783e8dc883"
13SRC_URI[sha256sum] = "c7b5e2853f0dd0b1aafea2f9e071941affeec3a76df8e3f6d67a718c89293555"
14
15UPSTREAM_CHECK_URI = "https://github.com/AbiWord/enchant/releases"
16
17S = "${WORKDIR}/enchant-${PV}"
18
19EXTRA_OEMAKE = "pkgdatadir=${datadir}/enchant-2"
20
21PACKAGECONFIG ??= "aspell"
22PACKAGECONFIG[aspell] = "--with-aspell,--without-aspell,aspell,aspell"
23PACKAGECONFIG[hunspell] = "--with-hunspell,--without-hunspell,hunspell,hunspell"
24
25FILES_${PN} += " \
26 ${datadir}/enchant-2 \
27 ${libdir}/enchant-2 \
28"
29FILES_${PN}-staticdev += "${libdir}/enchant-2/*.a"